New XRay Goggles link doesnt activate but old Hackasaurus link does

VERIFIED FIXED

Status

Webmaker
X-Ray Goggles
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: codekat, Assigned: jbuck)

Tracking

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Last night I ran a Train the Trainers at Tate Britain here in the UK to teach them how to use XRay Goggles to remix their digital collections. 

On my computer this works fine (Mac laptop) but on their Mac and PC desktops, going to the Tate Britain homepage at http://www.tate.org.uk/visit/tate-britain , we were unable to activate via the new XRay Goggles (at https://goggles.webmaker.org/en-US ). However, we were able to activate via the *old* Hackasaurus link (ie www.hackasaurus.org ). 

We tried this on several different laptops, computers etc, but it worked on none except mine. 

Not sure why this is an issue, but it's a big one! Especially when we're trying to show how easy the tool is to use at partner workshops ;) So, hoping someone can figure it out!
wat.  I can't reproduce that - but we gotta get to the bottom of that :(
Any idea what browsers they were running, Kat?

Any chance you could go back and get web consoles or other diagnostic means?  Or just get someone there on the phone while we live troubleshoot?
(Reporter)

Comment 3

4 years ago
Yeah, sorry I can't reproduce it either. They're a very new partner working with us so I'd rather not have to ask them that - but if I'm back in the studio I'll do it myself. 

The browsers we tried installing the (new) add-on to were Safari and Firefox both. Computers were brand new fancy desktop Macs and a few equally new PCs.
(Assignee)

Comment 4

4 years ago
I can recreate this in my copy of Firefox:

[11:04:02.655] GET https://webmaker.org/undefined/strings/undefined/en-CA [HTTP/1.1 404 Not Found 129ms]
[11:04:02.730] "Localized Error: HTTP error 404"
Assignee: nobody → jon
Status: NEW → ASSIGNED
(Assignee)

Comment 5

4 years ago
Looks like the problem is with localisation, I have an older version of the bookmark that looks like this:

javascript:(function(){var%20script=document.createElement('script');script.src='https://goggles.webmaker.org/webxray.js';script.className='webxray';document.body.appendChild(script);})();

If I visit the page now, it looks like:

javascript:(function(){var%20script=document.createElement('script');script.src='https://goggles.webmaker.org/en-CA/webxray.js';script.className='webxray';script.dataset.lang='en-CA';script.dataset.baseuri='https://goggles.webmaker.org/en-CA';document.body.appendChild(script);})();
(Assignee)

Comment 6

4 years ago
Created attachment 8336139 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/65
Attachment #8336139 - Flags: review?(pomax)
Attachment #8336139 - Flags: review?(pomax) → review?(ali)
Comment on attachment 8336139 [details] [review]
https://github.com/mozilla/goggles.webmaker.org/pull/65

Tested and it's working now.
Attachment #8336139 - Flags: review?(ali) → review+

Comment 8

4 years ago
Commit pushed to master at https://github.com/mozilla/goggles.webmaker.org

https://github.com/mozilla/goggles.webmaker.org/commit/dfde3821ecf32d834251e7eb9f545ccd22dd388a
Fix bug 940940 - Default to en-US if no locale data set
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
My old bookmark is working now. :codekat - Thanks for reporting this issue! :)
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.