Closed Bug 940965 Opened 6 years ago Closed 6 years ago

Intermittent TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/parallel/ic-setelement.js | --ion-eager --ion-check-range-analysis --no-sse3 | Assertion failure: 0 == rv, at nsprpub/pr/src/pthreads/ptthread.c:847

Categories

(Core :: JavaScript Engine: JIT, defect)

x86
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla29
Tracking Status
firefox27 --- unaffected
firefox28 --- unaffected
firefox29 --- fixed
firefox-esr24 --- unaffected
b2g-v1.2 --- unaffected

People

(Reporter: cbook, Assigned: nbp)

References

()

Details

(Keywords: assertion, intermittent-failure)

Linux mozilla-inbound leak test build on 2013-11-20 00:26:57 PST for push d9e2cb0a838d

slave: bld-linux64-ec2-148

https://tbpl.mozilla.org/php/getParsedLog.php?id=30821037&tree=Mozilla-Inbound

TEST-UNEXPECTED-FAIL | js/src/jit-test/tests/parallel/ic-setelement.js | --ion-eager --ion-check-range-analysis --no-sse3
INFO stderr         2> Assertion failure: 0 == rv, at ../../../../../nsprpub/pr/src/pthreads/ptthread.c:847
make[1]: *** [check-jit-test] Error 2
Blocks: 950044
I cannot reproduce this issue on my computer.

Shu, I guess you might want to have a look at this issue while running this test case with
  --ion-eager --ion-check-range-analysis --no-sse3 --available-memory=512
Flags: needinfo?(shu)
https://hg.mozilla.org/mozilla-central/rev/4f541dfa1a41
Assignee: nobody → nicolas.b.pierron
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Target Milestone: --- → mozilla29
Clearing needinfo since this got fixed.
Flags: needinfo?(shu)
You need to log in before you can comment on or make changes to this bug.