Closed Bug 940995 Opened 6 years ago Closed 6 years ago

Turn off builds for Mongolian (mn) Firefox desktop

Categories

(Firefox Build System :: General, defect)

25 Branch
defect
Not set

Tracking

(firefox26+ fixed, firefox27+ fixed, firefox28 unaffected, b2g-v1.2 fixed)

VERIFIED FIXED
mozilla26
Tracking Status
firefox26 + fixed
firefox27 + fixed
firefox28 --- unaffected
b2g-v1.2 --- fixed

People

(Reporter: Pike, Assigned: lsblakk)

References

Details

Attachments

(2 files)

+++ This bug was initially created as a clone of Bug #940979 +++

The Mongolian localization effort dissolved long ago and there are very few, if any, Mongolian users on Firefox desktop. We'd like to turn off their builds until a new effort comes to take over the localization.

We'll want to remove mn from all-locales and shipped-locales across all branches.
Actually, this affects only aurora and beta, but not central. We disabled the builds there a while ago.
Tracking since this changes upcoming merge process a bit, but not really a critical issue.
No need to track for 28 since this is already disabled there.
Is removing mn from those two files the only work here to turn off builds?  Anything else we need to get Releng or other infra on?
Attachment #8335657 - Flags: review?(l10n)
Attachment #8335662 - Flags: review?(l10n)
Attachment #8335662 - Flags: approval-mozilla-beta?
Attachment #8335657 - Flags: approval-mozilla-aurora+
The releng side of things is in bug 940979, and I'll need to do some manual database wizardry on the l10n dashboard, too.
Attachment #8335657 - Flags: review?(l10n) → review+
Attachment #8335662 - Flags: review?(l10n) → review+
Attachment #8335662 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Hey Ryan, not sure what flags get your attention so setting checkin needed and status but this will need to land before we merge mozilla-beta to mozilla-release so adding a ni? to get your help with that. Thank you.
Flags: needinfo?(ryanvm)
https://hg.mozilla.org/releases/mozilla-aurora/rev/51d1abbf077a
https://hg.mozilla.org/releases/mozilla-beta/rev/11a6c2c6af79
Assignee: nobody → lsblakk
Status: NEW → RESOLVED
Closed: 6 years ago
Flags: needinfo?(ryanvm)
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 26
Pulled Mongolian from the dashboard, too. Confirmed via https://l10n.mozilla.org/shipping/l10n-changesets?av=fx26 that Mongolian doesn't show up on the l10n-changesets anymore.

Next up is bug 942241, removing it from the website aka product-details.
Blocks: 942241
Status: RESOLVED → VERIFIED
Blocks: 958599
Component: Build Config → General
Product: Firefox → Firefox Build System
Target Milestone: Firefox 26 → mozilla26
You need to log in before you can comment on or make changes to this bug.