caret blinking behavior in modern theme (off-cycle?)

VERIFIED DUPLICATE of bug 59546

Status

()

P4
minor
VERIFIED DUPLICATE of bug 59546
18 years ago
17 years ago

People

(Reporter: bugzilla, Assigned: mjudge)

Tracking

Trunk
mozilla1.0.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [caret])

(Reporter)

Description

18 years ago
This applies only to the modern theme:

in all dialog input-fields (including location bar), the cursor seems to have
wrong blinking "logic". it starts invisible when moved / other widget focused, and 
then starts to blink. quit annoying with some dialogs (e.g. file->new->address
book card) when you press tab a few times, and the cursor is about half a second
invisible.

Comment 1

18 years ago
A whole half a second? I didn't see it disappear for long enough for me to
wonder where it went. And the box with  the focus is outlined, and that changes
instantly, so there's no ambiguity about which text box now has focus.

(Although it did seem to blink only while actually hovering over the dialouge
box. Is that a bug or a feature?)
(Reporter)

Comment 2

18 years ago
I know its a minor issue, but although the focused inputfields are framed bold you
dont know where the cursor is _exactly_ (that means between which characters, if
had moved it previously)

Perhaps half a second is a little long but with slow cursor blinking speed ...

And finally it shouldnt be hard to fix (classic theme behaves correcly)
(Reporter)

Comment 3

18 years ago
Btw. "my" cursor does blink all the time (doesnt need to be hovered), using
windows. Perhaps you're using a windowmanager with different focusing behavior?
(Focus on "mousemoveover")

Comment 4

18 years ago
over to editor
Assignee: hewitt → beppe
Component: Themes → Editor
QA Contact: pmac → sujay

Comment 5

18 years ago
mike
Assignee: beppe → mjudge
Priority: -- → P4
Whiteboard: [caret]
Target Milestone: --- → mozilla1.0.1

Comment 6

18 years ago
this sounds like another bug but I can't find it; maybe Simon knows of such a 
bug?
Summary: cursor blinking behavior in modern theme → caret blinking behavior in modern theme (off-cycle?)

Comment 7

18 years ago


*** This bug has been marked as a duplicate of 59546 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 8

18 years ago
verify dup
Status: RESOLVED → VERIFIED
OS: Windows ME → All
Hardware: PC → All
You need to log in before you can comment on or make changes to this bug.