Shutdown and or session bustage on closing the browser while active hardware media in use

RESOLVED WORKSFORME

Status

()

Firefox for Android
General
RESOLVED WORKSFORME
4 years ago
a year ago

People

(Reporter: aaronmt, Assigned: bnicholson)

Tracking

({reproducible})

27 Branch
ARM
Android
reproducible
Points:
---

Firefox Tracking Flags

(firefox27 affected, firefox28 affected, fennec27+)

Details

(Reporter)

Description

4 years ago
Currently when one swipes the browser off the application recents list in Android, some fault in browser shutdown or session restore happens.

Steps

i) http://mozilla.github.io/webrtc-landing/gum_test.html
ii) Share Video
iii) Swipe the browser off the application recents list
iv) Launch the browser

Expected: About:Home
Actual: http://mozilla.github.io/webrtc-landing/gum_test.html

Bonus: Console continues to spew camera messages despite it not being in use

E/QualcommCamera(  245): Qint android::get_camera_info(int, camera_info*): E
(Reporter)

Updated

4 years ago
OS: Mac OS X → Android
Hardware: x86 → ARM
Brian - How is this supposed to work? How does the webrtc notification foreground stuff effect it?
tracking-fennec: ? → 27+
Flags: needinfo?(bnicholson)
(Assignee)

Comment 2

4 years ago
After bug 885783, swiping Fennec from the recent apps should immediately kill Fennec and remove any WebRTC notifications (explanation in https://bugzilla.mozilla.org/show_bug.cgi?id=885783#c22). Only active downloads should keep Fennec alive.

I thought this was just fixed in bug 932816. Aaron, does this mean bug 932816 still isn't fixed, or are these symptoms different?
Flags: needinfo?(bnicholson)
(Reporter)

Comment 3

4 years ago
We kill the notification, I just have no idea if the browser is cleanly shutdown here or what. It's trivial to reproduce. My console floods with [1] after I swipe the browser off the list, so I have no idea what's going on here.

E/QualcommCamera(  245): Qint android::get_camera_info(int, camera_info*): E
Assignee: nobody → bnicholson
(Assignee)

Comment 4

4 years ago
WFM on my HTC One. Aaron, which phone are you using?

When you reopen the browser, is it loading from a cold state, triggering a session restore, and reloading the page? Or is it not being killed to begin with, and so the page is still open? If the former, we have a bug with session restore; if the latter, we have a bug with foreground notifications.

Also, would you mind posting a logcat when this all happens?
Flags: needinfo?(aaron.train)
(Reporter)

Comment 5

4 years ago
Oddly enough this now works for me when re-testing on Nightly and Aurora (29.0, 12/13). I am using an LG Nexus 4 (Android 4.4.2) today; when I launch the browser icon I am situated back on about:home instead of the previous page. When I visit History, I see the page listed under tabs from last time.

Here are some logs:

Sharing video and swipe off my app list --

W/WindowManager(  599): Force-removing child win Window{43044768 u0 SurfaceView} from container Window{42f9c3c0 u0 org.mozilla.fennec/org.mozilla.fennec.App}
W/WindowManager(  599): Failed looking up window
W/WindowManager(  599): java.lang.IllegalArgumentException: Requested window android.os.BinderProxy@42915200 does not exist
W/WindowManager(  599): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:7923)
W/WindowManager(  599): 	at com.android.server.wm.WindowManagerService.windowForClientLocked(WindowManagerService.java:7914)
W/WindowManager(  599): 	at com.android.server.wm.WindowState$DeathRecipient.binderDied(WindowState.java:1047)
W/WindowManager(  599): 	at android.os.BinderProxy.sendDeathNotice(Binder.java:493)
W/WindowManager(  599): 	at dalvik.system.NativeStart.run(Native Method)
I/WindowState(  599): WIN DEATH: null

Launch of Nightly icon --

I/ActivityManager(  599): START u0 {act=android.intent.action.MAIN cat=[android.intent.category.LAUNCHER] flg=0x10200000 cmp=org.mozilla.fennec/.App} from pid 7652
I/ActivityManager(  599): Start proc org.mozilla.fennec for activity org.mozilla.fennec/.App: pid=27685 uid=10176 gids={50176, 3003, 1028, 1015}
W/GeckoProfile(27685): requested profile directory missing: null
D/FaviconCache(27685): Favicon cache fullness: 0/524288
D/GeckoLocales(27685): Calling setContextGetter: org.mozilla.fennec.App@4224b580
D/GeckoSessInfo(27685): Building SessionInformation from prefs: 0, 0, true, false
W/GeckoEventDispatcher(27685): unregisterEventListener: event 'Prompt:ShowTop' has no listeners
D/GeckoProfile(27685): Found profile dir: /data/data/org.mozilla.fennec/files/mozilla/idqf3wnt.default
I/GeckoApp(27685): Creating BrowserHealthRecorder.
D/GeckoApp(27685): OS locale is en_US, app locale is null
D/GeckoHealthRec(27685): Initializing. Dispatcher is org.mozilla.gecko.util.EventDispatcher@4224f938
D/GeckoHealthRec(27685): Initializing profile cache.
I/GeckoLogger(27685): fennec :: GeckoProfileInfo :: Restoring ProfileInformationCache from file.
D/GeckoHealthRec(27685): Successfully restored state. Initializing storage.
D/GeckoHealthRec(27685): Done initializing profile cache. Beginning storage init.
D/GeckoSessInfo(27685): Recording start of session: 1386958540480

I'll re-open if I see this on another device.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(aaron.train)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.