SeaMonkey (linux) 2.22.1 breaks Lightning 2.7b1

RESOLVED WORKSFORME

Status

Calendar
Lightning: SeaMonkey Integration
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: NoOp, Unassigned)

Tracking

Lightning 2.7
All
Linux

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 SeaMonkey/2.22 (Beta/Release)
Build ID: 20131028185648

Steps to reproduce:

Upgraded SeaMonkey from 2.22.0 to 2.22.1 linux 32 and 64 bit versions.


Actual results:

Lightning calendar 2.7b1 ceases to function (see screenshot). Note: 2.7b1 is the recommended version according to <https://developer.mozilla.org/en-US/docs/Mozilla/Calendar/Calendar_Versions?>


Expected results:

Upgrade to SeaMonkey 2.22.1 should not have affected Lightning 2.7b1. Backing down to SeaMonkey 2.22.0 restores Lightning's calendar features/functions.
(Reporter)

Updated

4 years ago
Hardware: x86_64 → All
(Reporter)

Comment 1

4 years ago
Well... I would have added a screenshot, but each time that I try to add, buggy bugzilla keeps giving:

Bugzilla has suffered an internal error:

Undefined subroutine Fh::slice at /data/www/bugzilla.mozilla.org/extensions/Persona/template/en/default/hook/global/header-additional_header.html.tmpl line 63

The Bugzilla maintainers have been notified of this error.

Updated

4 years ago
Component: MailNews: General → Lightning: SeaMonkey Integration
Product: SeaMonkey → Calendar
Version: SeaMonkey 2.22 Branch → Lightning 2.7

Comment 3

4 years ago
Created attachment 8335782 [details]
20131119-sm2-22-1-lightning-bug.jpg

SM-2.22.1+Lg-2.7b1 image

Comment 4

4 years ago
<http://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/2.7b1-candidates/build1/linux-x86_64/>

And SM-2.22.1 from here:-
<ftp://ftp.mozilla.org/pub/mozilla.org/seamonkey/releases/2.22.1/contrib/seamonkey-2.22.1.en-US.linux-x86_64.tar.bz2> 

on a fresh new bare install, and it won't even load my local calendars, much less a web-based one.

Comment 5

4 years ago
This is most probably the known problem for Linux platform (compare Bug 925823 and https://blog.mozilla.org/calendar/2013/10/dont-upgrade-to-thunderbird-24-0-1-yet/) and is caused by Toolkit Bug 927073. 

The fix was recently ported back to various branches including mozilla-esr24, therefore I would assume the next SeaMonkey Beta build should pick up the fix.

Comment 6

4 years ago
We would also need the MOZ_FOLD_LIBS patch which I just landed (Bug 915574).

Comment 7

4 years ago
MOZ_FOLD_LIBS is not enabled for Thunderbird in current release builds, therefore SeaMonkey 2.22 should be fine.
https://mxr.mozilla.org/comm-esr24/search?string=MOZ_FOLD_LIBS
https://mxr.mozilla.org/comm-release/search?string=MOZ_FOLD_LIBS

Comment 8

4 years ago
Seamonkey 2.23 beta 1 still affected using Lightning versions 2.8b1 and 2.7b1.

Comment 9

4 years ago
According to <https://hg.mozilla.org/releases/comm-beta/> Seamonkey 2.23b1 was build without the fix for Bug 915574 and therefore it is expected that Lightning 2.8b1 doesn't work. It seems that the fix is contained in Seamonkey 2.23b2, maybe you can retest once it is released or retest using the unreleased test build from <https://ftp.mozilla.org/pub/mozilla.org/seamonkey/nightly/2.23b2-candidates/>
(Reporter)

Comment 10

4 years ago
Lightning	2.8b1	true	{e2fda1a4-762b-4020-b5ad-a41df1933103}
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23

Does not work. Same issue as before. I'll try the 32bit version of SM 2.23.
(Reporter)

Comment 11

4 years ago
32bit SM 2.23 & 2.8b1 does not work either.
Mozilla/5.0 (X11; Linux i686 on x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23
Lightning	2.8b1	true	{e2fda1a4-762b-4020-b5ad-a41df1933103}
(Reporter)

Comment 12

4 years ago
Tried to submit a screenshot, but I keep getting:

Bugzilla has suffered an internal error:

Undefined subroutine Fh::slice at /data/www/bugzilla.mozilla.org/extensions/Persona/template/en/default/hook/global/header-additional_header.html.tmpl line 63

The Bugzilla maintainers have been notified of this error.

Comment 13

4 years ago
Lightning 2.8b1 doesn't work with SeaMonkey 2.23 because it was not rebuild after landing the two fixes for Bug 927073. According to objdump the file libcalbasecomps.so still depends on "xul26.0" but the fixed libxul.so shipped with SeaMonkey announces only "xul26".

A later Lightning 2.8b1 test build doesn't show the problem anymore. I tested the one from <https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-beta-linux/1386568018/> build on 09-Dec-2013.

A Lightning 2.8b2 release would be required to support SeaMonkey 2.23 on Linux.

Comment 14

4 years ago
Its working! Both on 32 and 64 bit builds.
BTW the 64 bit builds are at:

https://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/tinderbox-builds/comm-beta-linux64/1386568018/
(Reporter)

Comment 15

4 years ago
Stefan & Kertesz = both of those builds (comment 13 & 14) are working for me. Thanks!
Mozilla/5.0 (X11; Linux x86_64; rv:26.0) Gecko/20100101 Firefox/26.0 SeaMonkey/2.23
Lightning	2.8b1	true	{e2fda1a4-762b-4020-b5ad-a41df1933103}
(Reporter)

Comment 16

4 years ago
Works for me.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.