Closed Bug 941222 Opened 8 years ago Closed 7 years ago

[User Story] Sheets Manager: List windows

Categories

(Firefox OS Graveyard :: Gaia::System::Window Mgmt, defect)

x86
macOS
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 967428

People

(Reporter: pdol, Unassigned)

References

Details

(Keywords: uiwanted, Whiteboard: [ucid:System132, 1.4:P2, ft:systems-fe], system-browser)

User Story:
As a user I want to view a list of open browsing windows so I can see what pages I currently have loaded.

Acceptance Criteria:
1. I am able to open a view to a list of my open browsing windows.
Component: Gaia::System → Gaia::System::Window Mgmt
Component: Gaia::System::Window Mgmt → Gaia::System::Browser
No longer blocks: browser-chrome-mvp
Should this live in the window manager component as it's now part of the task manager?

Francis, is there anything special about the presentation of browser windows vs app windows?
Component: Gaia::System::Browser Chrome → Gaia::System::Window Mgmt
Flags: needinfo?(fdjabri)
Keywords: uiwanted
Flags: in-moztrap?(nhirata.bugzilla)
Flags: in-moztrap?(nhirata.bugzilla) → in-moztrap?(jsmith)
No longer blocks: 1.4-systems-fe
Flags: in-moztrap?(jsmith)
(In reply to Ben Francis [:benfrancis] from comment #1)
> Should this live in the window manager component as it's now part of the
> task manager?
> 
> Francis, is there anything special about the presentation of browser windows
> vs app windows?


Hi Ben, as we've discussed, this use case is now handled by the Task Manager, so there's no need for a separate windows manager. Browser windows should display the page title, whereas app windows display the app title. Please see the latest spec on Box for more details: https://mozilla.box.com/s/638ltapmruk7l0vo8mou
Flags: needinfo?(fdjabri)
(In reply to Francis Djabri [:djabber] from comment #2)
> this use case is now handled by the Task Manager, so there's no need for a separate windows manager. 

Do we need this bug anymore then?
Flags: needinfo?(bfrancis)
Probably not, though we should test "Browser windows should display the page title, whereas app windows display the app title" to verify this is working correctly.
Flags: needinfo?(bfrancis)
(In reply to Ben Francis [:benfrancis] from comment #4)
> Probably not, though we should test "Browser windows should display the page
> title, whereas app windows display the app title" to verify this is working
> correctly.

The user story in bug 967428 captures this well I think, so marking as a duplicate for now.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 967428
You need to log in before you can comment on or make changes to this bug.