Closed Bug 941247 Opened 6 years ago Closed 6 years ago

Zone::CompartmentGCState should be named Zone::GCState

Categories

(Core :: JavaScript Engine, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla28

People

(Reporter: jimb, Assigned: jimb)

Details

(Whiteboard: [qa-])

Attachments

(1 file)

Zone::CompartmentGCState describes the gc state of the zone, not a compartment. The attached patch renames it Zone::GCState.
Attachment #8335543 - Flags: review?(jcoppeard)
Comment on attachment 8335543 [details] [diff] [review]
Rename Zone::CompartmentGCState to Zone::GCState.

Review of attachment 8335543 [details] [diff] [review]:
-----------------------------------------------------------------

Great, thanks for doing this!
Attachment #8335543 - Flags: review?(jcoppeard) → review+
https://hg.mozilla.org/integration/mozilla-inbound/rev/a8769cefb478
Flags: in-testsuite-
Target Milestone: --- → mozilla28
https://hg.mozilla.org/mozilla-central/rev/a8769cefb478
Assignee: nobody → jimb
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [qa-]
You need to log in before you can comment on or make changes to this bug.