[B2G][Camera][Camera] Live camera can be seen behind a photo being viewed

VERIFIED DUPLICATE of bug 934366

Status

VERIFIED DUPLICATE of bug 934366
5 years ago
5 years ago

People

(Reporter: lmauritson, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g18 affected, b2g-v1.2 affected)

Details

(Whiteboard: burirun4)

Attachments

(1 attachment)

4.99 MB, video/quicktime
Details
(Reporter)

Description

5 years ago
Created attachment 8335737 [details]
Video

When switching between portrait and landscape mode while taking and viewing pictures sometimes the live camera can be seen on the edge of the screen normally occupied by recently taken photos.

Repro Steps:
1) Updated Buri/Inari/Leo/Unagi to BuildID: 20131120004000
2) Select Camera from the home menu
3) Hold the camera in portrait mode and take 5 or more pictures rapidly
4) Turn the device in to landscape mode and take a picture
5) Quickly view taken the picture and turn the camera back to portrait mode.
6) Turn the camera back to landscape mode.

Actual:
After step six the recently taken photo bar will disappear and in the space it occupied the live camera can be seen behind the photo being viewed.

Expected:
The live camera cannot be seen while viewing a photo.

Environmental Variables:
Device: Buri v1.2 MOZ RIL
BuildID: 20131120004000
Gaia: 5ec2963fff60492c840707df8d8090f9908a5251
Gecko: 2d454e0de2ed
Version: 26.0

Repro frequency: 75%

See attached: Video of bug in action
(Reporter)

Comment 1

5 years ago
This issue occurs on v1.1 as well.

Environmental Variables:
Device: Leo 1.1 MOZ RIL
BuildID: 20131114041200
Gaia: cdcb99873ad8133a6500884feee5a3e0e957d302
Gecko: 7c3cfc0936ca
Version: 18.0
status-b2g18: --- → affected
status-b2g-v1.2: --- → affected
Whiteboard: burirun4
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 934366
(Reporter)

Comment 3

5 years ago
Verified as duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.