Progress message on Firefox Stub install for Japanese and other languages that don't break words with spaces.

VERIFIED FIXED in Firefox 26, Firefox OS v1.2

Status

()

VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: m_kato, Assigned: rstrong)

Tracking

Trunk
Firefox 28
x86_64
Windows 8.1
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox25- wontfix, firefox26+ verified, firefox27+ verified, firefox28 verified, b2g-v1.2 fixed)

Details

Attachments

(2 attachments, 1 obsolete attachment)

Created attachment 8335774 [details]
IMG 2013-11-21 11.19.31.png

When using JPN version of Stub installer from https://ftp.mozilla.org/pub/mozilla.org/firefox/releases/25.0/win32/ja/Firefox%20Setup%20Stub%2025.0.exe, the haiku? message on progress dialog seems to be out of screen.  But when using ENG version, no problem.

See screenshot.
I tested Japanese when I wrote the stub installer and it worked then. Could you check older versions of the Japanese stub installer to see if it reproduces with them as well? Thanks
Flags: needinfo?(m_kato)
(In reply to Robert Strong [:rstrong] (do not email) from comment #1)
> I tested Japanese when I wrote the stub installer and it worked then. Could
> you check older versions of the Japanese stub installer to see if it
> reproduces with them as well? Thanks

I test using Firefox Setup Stub 24.0.exe from http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/24.0/win32/ja/, same issue occurs too.

Screenshot is on windows 7 JPN, but I can reproduce on Windows 8.1 JPN
Flags: needinfo?(m_kato)
I'm a tad surprised that this wasn't reported previously. Do you have a second Win 7 JPN system that you can test on so the possibility that it is system specific can be lessened?
Flags: needinfo?(m_kato)
maybe dpi related?
(In reply to Robert Strong [:rstrong] (do not email) from comment #3)
> I'm a tad surprised that this wasn't reported previously. Do you have a
> second Win 7 JPN system that you can test on so the possibility that it is
> system specific can be lessened?

Mozilla Japan web site doesn't offer stub installer, so anyone cannot hit this issue.

Also, although I test JPN stub installer on Windows 8 US verison, this problem occurs this.

(In reply to Brian R. Bondy [:bbondy] from comment #4)
> maybe dpi related?

No. I use DPI is 100%.
Flags: needinfo?(m_kato)
http://www.mozilla.jp/firefox/ always offers full installer, not stub installer
In Japanese locale for stub is here. https://hg.mozilla.org/l10n-central/ja/file/151d7fb11e83/browser/installer/nsisstrings.properties

INSTALL_BLURB3 in JA properties has no "\n" and space, all string maybe one line...
Does this only happen with INSTALL_BLURB3 and the first two display correctly?
Note: the en-US version overrides the following so it displays the haiku
http://mxr.mozilla.org/mozilla-central/source/browser/locales/en-US/installer/nsisstrings.properties#26

The override has "\n" so each section of the haiku is on a newline otherwise it just wraps the text.
http://mxr.mozilla.org/mozilla-central/source/browser/installer/windows/nsis/stub.nsi#263
(In reply to Robert Strong [:rstrong] (do not email) from comment #8)
> Does this only happen with INSTALL_BLURB3 and the first two display
> correctly?

No. INSTALL_BLURB2 in JA is pretty long too, so position is wrong.

If INSTALL_BLURBx has lone sentence that has no "\n" and space, this problem seems to occur.
Thanks m_kato! I was able to reproduce and should be able to figure this out.
Assignee: nobody → robert.bugzilla
Status: NEW → ASSIGNED
Created attachment 8336647 [details] [diff] [review]
patch rev1 - remove DT_NOFULLWIDTHCHARBREAK flag

I misunderstood the behavior of the DT_NOFULLWIDTHCHARBREAK flag and thought it behaved differently when combined with the DT_WORDBREAK... meh!
Attachment #8336647 - Flags: review?(netzen)
status-firefox25: --- → affected
status-firefox26: --- → affected
status-firefox27: --- → affected
status-firefox28: --- → affected
tracking-firefox25: --- → ?
tracking-firefox26: --- → ?
tracking-firefox27: --- → ?
Summary: Progress message on Firefox Stub install for Japanese version is out of dialog box. → Progress message on Firefox Stub install for Japanese and other languages that don't break words with spaces.
Target Milestone: --- → Firefox 28
Created attachment 8336652 [details] [diff] [review]
patch - remove DT_NOFULLWIDTHCHARBREAK flag

Forgot to comment out the STUB_DEBUG define
Attachment #8336647 - Attachment is obsolete: true
Attachment #8336652 - Flags: review?(netzen)
Attachment #8336647 - Flags: review?(netzen)
Attachment #8336652 - Flags: review?(netzen) → review+
Flags: in-testsuite-
https://hg.mozilla.org/mozilla-central/rev/a1d6c5cd7b2d
Status: ASSIGNED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
status-firefox28: affected → fixed
Comment on attachment 8336652 [details] [diff] [review]
patch - remove DT_NOFULLWIDTHCHARBREAK flag

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 322206 which implemented the stub installer
User impact if declined: at minimum the ja, zh-TW, and zh-CN locales will not display the marketing blurbs correctly during the downloading and installation phase when installing from the stub installer.
Testing completed (on m-c, etc.): Manually tested using latest nightly and using a local build using the strings from the ja locale
Risk to taking this patch (and alternatives if risky): minimal.
String or IDL/UUID changes made by this patch: None

Note: since this only affects certain localized builds which aren't well tested (hence why this is only being reported now) I'd like to get this uplifted to branches so the change is tested and so users don't experience this bug which might make them cancel the installation.
Attachment #8336652 - Flags: approval-mozilla-beta?
Attachment #8336652 - Flags: approval-mozilla-aurora?
Comment on attachment 8336652 [details] [diff] [review]
patch - remove DT_NOFULLWIDTHCHARBREAK flag

Let's get testing around this before release.
Attachment #8336652 - Flags: approval-mozilla-beta?
Attachment #8336652 - Flags: approval-mozilla-beta+
Attachment #8336652 - Flags: approval-mozilla-aurora?
Attachment #8336652 - Flags: approval-mozilla-aurora+
Juan can you put this at the top of your testing for 26.0b8 ?
tracking-firefox25: ? → -
tracking-firefox26: ? → +
tracking-firefox27: ? → +
Flags: needinfo?(jbecerra)
https://hg.mozilla.org/releases/mozilla-aurora/rev/fd75c8f6cc7d
https://hg.mozilla.org/releases/mozilla-beta/rev/070d5dcee33d
status-firefox25: affected → wontfix
status-firefox26: affected → fixed
status-firefox27: affected → fixed
status-b2g-v1.2: --- → fixed

Updated

5 years ago
Keywords: verifyme
Mozilla/5.0 (Windows NT 6.3; WOW64; rv:26.0) Gecko/20100101 Firefox/26.0

Verified as fixed on Windows 8.1 x64 using Firefox 26 beta 8 (buildID: 20131125215016).
status-firefox26: fixed → verified
While looking at this, I tried a few other locales like ar, el, and he, and I found that the "he" stub installer wasn't localized. I filed bug 943634 for that separate issue.
Flags: needinfo?(jbecerra)
Verified as fixed on Windows 8.1 x64 using latest Aurora (ja/zh-CN/zh-TW/ar/el builds).
status-firefox27: fixed → verified
Also verified as fixed on Windows 8.1 x64 using latest Aurora 28.0a2 (buildID: 2013121100400)
 - Verified with ja/ja-JP/zh-CN/zh-TW/ar/el/ru/xh builds.
status-firefox28: fixed → verified
Keywords: verifyme
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.