No search results on MDN (Google version of the search)

RESOLVED WORKSFORME

Status

Mozilla Developer Network
Search
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: Alice0775 White, Unassigned)

Tracking

Details

(Whiteboard: [specification][type:bug])

(Reporter)

Description

4 years ago
What did you do?
================
1. Open https://developer.mozilla.org/en-US/
2. Search "window"
3. 

What happened?
==============
No search result

What should have happened?
==========================
Search results display

Is there anything else we should know?
======================================
(Reporter)

Updated

4 years ago
Component: General → Site search
(Reporter)

Updated

4 years ago
Summary: Nothing search results → Nothing search results on MDN
I get plenty of results. Is this happening on the beta version of the site or on the non-beta version?
(Reporter)

Comment 2

4 years ago
(In reply to Jean-Yves Perrier [:teoli] from comment #1)
> I get plenty of results. Is this happening on the beta version of the site
> or on the non-beta version?


I think it is non-beta version
Yes, I can confirm on the non-beta version of the site. 

I remember we had this problem about one month ago and it just solved by itself after one or two hours. I will retest then.
Summary: Nothing search results on MDN → No search results on MDN (Google version of the search)
Looks like Google's js has an error?

http://screencast.com/t/gJH2EcVlxZ7
Looks like this is Firefox-only?
Resolving - a force-refresh on https://developer.mozilla.org/en-US/search?q=window works for me now.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 7

4 years ago
https://developer.mozilla.org/en-US/search?q=window

still no results on Firefox, Google Chrome and IE as well.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Doesn't work for me either. I tried on Chrome right now and empty result (didn't try a search there since months).

Force refresh (shift-reload) on Fx didn't solve the problem for me.
That's weird. Something I did - I changed the search results page to /es/ and it worked, then I went back to en-US and force-refreshed and it did.
Just tried this in Nightly and legacy design and search worked well.  Chrome the same.
Seeing this in both Firefox (release) and Chrome. Force refresh doesn't help in either.
(Reporter)

Comment 12

4 years ago
It works now.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
I'm still having the issues described in comment 11.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
Several people report this still happening.

Comment 15

4 years ago
Yep. Me, for one. Same diagnostics: Works in beta, not in current layout.

Console says

    [18:31:46.834] TypeError: a is undefined @ https://www.google.com/uds/api/search/1.0/65b21018ad4df09e3eb5a21326b72d0b/default+en.I.js:486
Still happens for me too. Maybe a Google error that has propagated its CDN and the fix is propagating little by little to them.
Still happening to me. Anything I can do to help?
Duplicate of this bug: 942634

Comment 19

4 years ago
Can it be a throttling issue? This page,

https://developers.google.com/web-search/docs/

suggests, that the API is deprecated and "the number of requests you may make per day will be limited".

Comment 20

4 years ago
It's been just over three years since the API was deprecated (on November 1, 2010). The deprecation policy listed at https://developers.google.com/web-search/docs/ says that "For a period of three years after an announcement (the "Deprecation Period"), Google will use commercially reasonable efforts to continue to operate the Deprecated Version of the Service and to respond to problems with the Deprecated Version of the Service deemed by Google in its discretion to be critical." So it sounds like Google may have recently stopped providing any support for the old API. They recommend switching to the API described at https://developers.google.com/custom-search/v1/overview.

Comment 21

4 years ago
Sorry, last URL was invalid. Correct URL is https://developers.google.com/custom-search/.
Good find Manuel & Karen - we're probably hitting the old custom search throttle limit. :/ We're going to drop CSE altogether in 2 weeks, so we only have a few options, all of them are a little stinky:

1. Do nothing and live with flaky search results
2. Spend dev time changing our CSE to the new API that we'll drop in 2 weeks
3. Turn on Elastic Search in the old design now

Votes, comments, opinions?
I vote for #2 or #3, whichever takes less time. Empty search results reinforce the idea that MDN search does not work, and it could be an uphill battle to get people to use the feature again when it does.

Comment 24

4 years ago
I agree with openjck--#2 or #3, whatever takes less effort.
There is a #4 point.

#4 Turn the redesign live now.

I'm not afraid of this one anymore, as of today.
Data: Of the last month of 6.8M page-views, /search/* got 135k of them - about 2%. So about 6k page-views per day are potentially affected. Can't tell what the failure rate is among those views. :(

David & Holly - what do you think about option #3 - enabling ES on the old design now? The only glaring deficiency I saw was that the pagination buttons have disappeared in the old design.
Flags: needinfo?(hhabstritt.bugzilla)
Flags: needinfo?(dwalsh)
Note: I did option #3 on the stage server already: https://developer.allizom.org/en-US/search?q=window
I say go for it.
Flags: needinfo?(dwalsh)

Comment 29

4 years ago
#3 or #4: Onwards for death and glory!

Missing pagination is IMHO a minor concern, mostly results are under the top two or three. If not, the situation is still better than ZARO results.
I enabled Elastic Search for all users on production.

Comment 31

4 years ago
Thanks, I am getting search results now. I agree with Manuel that the missing pagination is a minor concern, and the solution seems like a reasonable one given that it's only going to be used for a few weeks.
#3 works for me. However, we still need the following, which I'll work on this week:
- what we display in the page for 0 search results
- when hitting enter in an empty search field, we return results. I'm not sure how these results are determined. See screenshot -  http://cl.ly/image/010D2u0y2X2S. I can also provide something to show in this case.
Flags: needinfo?(hhabstritt.bugzilla)
The search has now been switched over to use Elasticsearch completely. Closing this since this seems out of date.
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.