Inconsistent page zoom behavior: loading page zoomed vs zooming later

RESOLVED DUPLICATE of bug 507728

Status

()

RESOLVED DUPLICATE of bug 507728
5 years ago
5 years ago

People

(Reporter: mehmet.yavuz.selim, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

* Open http://www.opengl.org/sdk/docs/man2/xhtml/glXSwapBuffers.xml. Ensure that the page was not zoomed. All is well.
* Zoom in with ctrl-mousewheel or ctrl-+ as many times as you want. All is well.
* Refresh page with F5. Text flows out of screen.
* Press Ctrl-0 to restore the default zoom. Text still flows out of screen.

Similar issue also happens with zoomed out pages. Zooming out after loading page works fine. Loading the page with zoomed-out state limits the rendered area of the page and shows a scrollbar.

This might be an issue with this specific page. But I find the inconsistent behavior between whether page is loaded zoomed-in or whether it is zoomed in later remarkable enough. Also, Chrome 31.0 and IE 10.0 behave fine when zooming this page.


Actual results:

Text flows out of screen when the page is loaded as zoomed-in.


Expected results:

Text should not flow out of screen when the page is loaded as zoomed-in. Instead, it should be rendered the same way as when the page is zoomed in after being loaded.
(Reporter)

Comment 1

5 years ago
Bug 507728 seems to be related or a duplicate.

Comment 2

5 years ago
Thanks for filing.  Bug 507728 does indeed seem to be a duplicate.  I can reproduce for XML files when the full-zoom option is turned on.  So I'll mark it as a duplicate, but if you find that you can reproduce on some non-XML page, then please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 507728
(Reporter)

Updated

5 years ago
Summary: Inconsistent page zoom behavior: loading paged zoomed vs zooming later → Inconsistent page zoom behavior: loading page zoomed vs zooming later
You need to log in before you can comment on or make changes to this bug.