Only show avatars for public users on events

VERIFIED FIXED

Status

Mozilla Reps
reps.mozilla.org
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: giorgos, Assigned: tasos)

Tracking

Details

(Whiteboard: [kb=1189395] )

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
1. A mozillian choses not to share personal info with other "mozilla corp sites" on their mozillian profile
2. Registers to reps.m.o
3. Because of (1) his name on reps.m.o is 'Anonymous Mozillian'

Problem: Avatar is displayed when anonymous user subscribes to an event

I see no benefit from allowing anonymous mozillians to subscribe to events, so I suggest we remove this functionality altogether for them. Special care, if a mozillian has subscribed to our portal, subscribed to some events and then opts-out from sharing information. Then we probably remove him from all subscribed events. Thoughts?

If we want to keep this functionality we should remove the avatar.
(Reporter)

Updated

4 years ago
Whiteboard: [kb=1189395]
(Reporter)

Updated

4 years ago
OS: Linux → All
Hardware: x86_64 → All
Created attachment 8336160 [details]
Screen Shot 2013-11-21 at 10.13.03 AM.png


> 
> I see no benefit from allowing anonymous mozillians to subscribe to events,

I think there is great benefit in allowing event planners to know how many are planning to attend, while simultaneously allowing attendees not to publish (to the entire internet!) their plans to be in a particular place at a particular time.

Suggestion: Add a count of attendees to the event page, and publish only those whose information is public. Something like, "42 attending, including...." 

I attach a (incredibly rought) mockup of this.
(Reporter)

Comment 2

4 years ago
(In reply to Justin Crawford [:hoosteeno] from comment #1)
> Created attachment 8336160 [details]
> Screen Shot 2013-11-21 at 10.13.03 AM.png
> 
> 
> > 
> > I see no benefit from allowing anonymous mozillians to subscribe to events,
> 
> I think there is great benefit in allowing event planners to know how many
> are planning to attend, while simultaneously allowing attendees not to
> publish (to the entire internet!) their plans to be in a particular place at
> a particular time.

That's a valid point. I based my opinion on the original concept of the feature which was designed so others can see which Reps are attending. Since that we broadened that feature Mozillians, this suggestions makes sense too.

> 
> Suggestion: Add a count of attendees to the event page, and publish only
> those whose information is public. Something like, "42 attending,
> including...." 
> 
> I attach a (incredibly rought) mockup of this.

/me likes
(In reply to Justin Crawford [:hoosteeno] from comment #1)
> Suggestion: Add a count of attendees to the event page, and publish only
> those whose information is public. Something like, "42 attending,
> including...." 
> 
> I attach a (incredibly rough) mockup of this.

I like this suggestion a lot. Thanks for the mockup too!
Updating the summary to match the solution we like.
Summary: Mozillians with private data should not be allowed to subscribe to events. → Only show avatars for public users on events
(Assignee)

Updated

4 years ago
Assignee: nobody → tasos
(Assignee)

Updated

4 years ago
Status: NEW → ASSIGNED

Comment 5

4 years ago
Commits pushed to master at https://github.com/mozilla/remo

https://github.com/mozilla/remo/commit/bc629bfb1b5dec6a7bff6b7c6d56ecd4c521a5a6
[fix bug 941533] Only show avatars for public users on events.

https://github.com/mozilla/remo/commit/c53a04272b1cf2b81f1cfa8cfaa1cbab5c89e566
Merge pull request #674 from akatsoulas/941533

[fix bug 941533] Only show avatars for public users on events.

Updated

4 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED

Updated

4 years ago
Version: unspecified → next
(Reporter)

Comment 6

4 years ago
Created attachment 8396208 [details]
Mozilla Reps - Test event nemo 2014-03-25 10-19-23.png

Verified fixed on stage. 

* I subscribed with a mozillian account that does not allow information sharing and I did not appear on the list.

* I subscribe with a mozillians account that allows information sharing and I do appear on the list

Thanks :tasos!
(Reporter)

Updated

4 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Updated

4 years ago
Version: next → 426
You need to log in before you can comment on or make changes to this bug.