Redeploy blog.getfirebug.com with content from SVN and location as appropriate

RESOLVED FIXED

Status

Infrastructure & Operations
WebOps: IT-Managed Tools
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: Honza, Assigned: jd)

Tracking

Details

(Whiteboard: [kanban:https://kanbanize.com/ctrl_board/4/189] [firebug-p1])

(Reporter)

Description

4 years ago
I can't modify the current Firebug theme stylesheets (Appearance > Editor > firebug.css), since the firebug.css file is not writable.

Wordpress says:
You need to make this file writable before you can save your changes.

Honza
(Assignee)

Comment 1

4 years ago
As this site is on a web cluster the files cannot be edited directly. You will need to modify them in the repo and file a bug for site code update. Repo is:

http://svn.mozilla.org/projects/getfirebug.com/tags/production/blog/wp-content/themes/firebug

Hope this helps.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

4 years ago
I already modified the repo.
Specifically this file:
http://svn.mozilla.org/projects/getfirebug.com/tags/production/blog/wp-content/themes/firebug/firebug.css
(revision 122607)

But this online file:
https://blog.getfirebug.com/getfirebug_content/themes/firebug/firebug.css

...has never been updated.

What I did wrong?

Honza
(Assignee)

Comment 3

4 years ago
Oh, well you just need to file a bug to get the code updated on the servers. We can use this bug for that this time.

I pulled the new code in for dev and stage. If you can make sure things look good I will update prod.
Status: RESOLVED → REOPENED
Resolution: INVALID → ---
(Assignee)

Updated

4 years ago
Assignee: nobody → jcrowe
Component: getfirebug.com → WebOps: Engagement
Product: Websites → Infrastructure & Operations
QA Contact: nmaul
Summary: Can't modify Firebug theme for Wordpress on getfirebug.com → Update Firebug theme for Wordpress on getfirebug.com
Version: unspecified → other
(Reporter)

Comment 4

4 years ago
(In reply to Jason Crowe [:jd] from comment #3)
> Oh, well you just need to file a bug to get the code updated on the servers.
> We can use this bug for that this time.
Thanks

> I pulled the new code in for dev and stage. If you can make sure things look
> good I will update prod.
Sounds great, what are the dev and stage URLs?

Honza
(Assignee)

Comment 5

4 years ago
blog.getfirebug-dev.allizom.org

blog.getfirebug.allizom.org

Unfortunately due to an ongoing bug in firefox you will need to use Chrome or another browser to access these dev sites.
(Reporter)

Comment 6

4 years ago
I loaded:
http://blog.getfirebug.allizom.org/getfirebug_content/themes/firebug/firebug.css
(but my changes are not there)

The following style is modified (see rev 122607)

h3 {
    margin: 15px 0 0 0;
    font-size: 16px;
    padding-top: 20px;                    <------------- new
    padding-bottom: 3px;                  <------------- new
    border-bottom: 1px solid lightgrey;   <------------- new
}

How should I test the blog.getfirebug-dev.allizom.org?
Authorization is required by this site but my Mozilla LDPA neither getfirebug.com credentials don't work.

Honza
(Assignee)

Comment 7

4 years ago
I sent the password to you for the dev site. The setting is not on that site either, however on the dev server I see

# cat blog/wp-content/themes/firebug/firebug.css | grep -A 6 'h3 {'
h3 {
    margin: 15px 0 0 0;
    font-size: 16px;
    padding-top: 20px;
    padding-bottom: 3px;
    border-bottom: 1px solid lightgrey;
}

So I am not sure where the web site is getting the file from but it must be another location. (This is generally why I do not recommend mixing the code form 3 CM systems in one directory tree).
(Assignee)

Comment 8

4 years ago
Well I found the update issue. It looks like this is more complicated that I thought. It seems like the blog code base was carved out from the main codease in order to facilitate upgrading wordpress. The issue is that the content files were not checked out of SVN and are simply residing as local files on the filesystem. This is no longer a quick fix as I will need to completly redeploy the blog site in order to get these files from SVN.

I have another bug to carve the mediawiki site out of the main codebase as well so I can hopefully do both of these at the same time. That time is not today however.

I went ahead and hacked this file into the dev and stage site (svn cat) so if that is the only necessary change then they should work. Altough I notice a database error on the dev site, so that is hosed now as well. The stage site is up.

Hope this helps somewhat for now.
Status: REOPENED → ASSIGNED
Summary: Update Firebug theme for Wordpress on getfirebug.com → Redeploy blog.getfirebug.com with content from SVN and location as appropriate
(Reporter)

Comment 9

4 years ago
(In reply to Jason Crowe [:jd] from comment #7)
> I sent the password to you for the dev site.
Unfortunately, the password doesn't work for me.

Honza
(Assignee)

Comment 10

4 years ago
Looking at the new location I see the username is getfirebug but I do not have that password. Someone on your team may have it or I can reset it if you like.
(Reporter)

Comment 11

4 years ago
(In reply to Jason Crowe [:jd] from comment #10)
> Looking at the new location I see the username is getfirebug but I do not
> have that password. Someone on your team may have it or I can reset it if
> you like.
I don't think anyone has it. Please reset and send it to me, thanks!

Honza
(Assignee)

Comment 12

4 years ago
new one sent, may take a few min for it to propogate.
(Reporter)

Comment 13

4 years ago
(In reply to Jason Crowe [:jd] from comment #12)
> new one sent, may take a few min for it to propogate.
I am seeing: Error establishing a database connection

Honza
Whiteboard: [firebug-p1] → [kanban:https://kanbanize.com/ctrl_board/4/189] [firebug-p1]
(Assignee)

Comment 14

3 years ago
This site has now been migrated to our new blog platform. I will leave the old site around for a few days, but am planning on decommissioning it early next week. I am leaving this bug open to track that work.
Component: WebOps: Engagement → WebOps: IT-Managed Tools
(Assignee)

Updated

3 years ago
Depends on: 1049757
(Assignee)

Comment 15

3 years ago
Clean up complete, closing this out now.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Blocks: 1049757
No longer depends on: 1049757
You need to log in before you can comment on or make changes to this bug.