Event fluffing can hit offscreen targets

RESOLVED WORKSFORME

Status

()

Core
Event Handling
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: daleharvey, Assigned: daleharvey)

Tracking

unspecified
1.3 Sprint 6 - 12/6
x86
Mac OS X
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:1.3+)

Details

(Whiteboard: [systemsfe] )

https://bugzilla.mozilla.org/show_bug.cgi?id=937929 suggests that our event fluffing code doesnt take into account whether the element is on screen or not (event fluffing requires layers so display: none'd elements shouldnt be possible), it may alternatively be a transform issue

Updated

4 years ago
Component: DOM: Events → Event Handling
Blocks: 937744
blocking-b2g: --- → koi?

Updated

4 years ago
blocking-b2g: koi? → koi+
Vivien, can you take this?  If not, is there someone else you'd suggest?
Flags: needinfo?(21)
I can probably have a shot at this
Assignee: nobody → dale
Whiteboard: [systemsfe]
Target Milestone: --- → 1.3 Sprint 6 - 12/6
Since dale is looking at it I don't think I have anything to do here :)
Flags: needinfo?(21)
This is being moved to 1.3, as bug 944347 is going to disable event fluffing for 1.2.
blocking-b2g: koi+ → 1.3+
Not particularly easy to diagnose, experiment on desktop with position: absolute and css translations do the right thing, thinking that the disregarding of invisible frames is happening in http://mxr.mozilla.org/mozilla-central/source/layout/base/nsLayoutUtils.cpp#2061

Given that this was hard to reproduce in the case of the browser, it may be something else, if there was a single hitable pixel that overlapped the visible border then it would still be easy to hit consistently with fluffing

Trying to drill down from the browser failing case right now
So I have tried to reproduce https://bugzilla.mozilla.org/show_bug.cgi?id=937744 and https://bugzilla.mozilla.org/show_bug.cgi?id=937929 (requires commenting out https://github.com/mozilla-b2g/gaia/blob/master/apps/browser/js/browser.js#L515) on a peak on both master and 1.2 and I can no longer reproduce either of those bugs.

The event fluffing code looks to correctly disregard hidden elements, right now I am stuck on this bug, will needinfo jason to see if theres any way to drill down STR to device / branch
Flags: needinfo?(jsmith)
Keywords: qawanted
Whiteboard: [systemsfe] → [systemsfe]
I'll have someone look at this today to see if they can still reproduce bug 937744.
Flags: needinfo?(jsmith)

Updated

4 years ago
QA Contact: sarsenyev

Comment 8

4 years ago
This bug is very similar to https://bugzilla.mozilla.org/show_bug.cgi?id=941313
However as per comment 7, I cannot reproduce the issue on 1.3 master and 1.2 builds, cannot open apps with swiping empty homescreen sheet or hit offscreen targets

Device: Buri 1.2 COM RIL
BuildID: 20131204004003
Gaia: 8d762f3376318fd6be390432db750ae4904c9ab6
Gecko: 758f3fb32dda
Version: 26.0
RIL version: 01.02.00.019.102
Firmware version: v1.2_20131115


Device: Buri 1.3 master
BuildID: 20131204115608
Gaia: 324c467fc6b202fd09efe4b16cd83960fd2901eb
Gecko: 526e12792fc8
Version: 28.0a1
Firmware version: v1.2_20131115
Keywords: qawanted
I have not been able to reproduce it neither. Maybe with other steps to reproduce...
Ok, https://bugzilla.mozilla.org/show_bug.cgi?id=937744 is identical to https://bugzilla.mozilla.org/show_bug.cgi?id=941313 and noone has been able to reproduce after this fix, so will close as a dupe

I will test https://bugzilla.mozilla.org/show_bug.cgi?id=937929 with the gaia fix reverted and if I cant reproduce then I will close this one as misdiagnosed
ok, tested and havent been able to reproduce
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.