Status

()

Core
General
RESOLVED DUPLICATE of bug 899194
4 years ago
4 years ago

People

(Reporter: mccr8, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
We need some kind of automated regression testing for B2G.
I already have some automation where I can start webpages within the browser app and collect results from elements of the page.  After I can upload them where we want.

Just tell me what page (that I can host my-self) to run and where to upload the result and I will setup the automation for you ;)
johns and kats are the experts here.
Whiteboard: [MemShrink] → [MemShrink:P1]
(Reporter)

Updated

4 years ago
Depends on: 931198

Comment 3

4 years ago
Hey guys I am already working on this, see Bug 899194
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899194
(Reporter)

Comment 5

4 years ago
Thanks, I figured we must have a bug for this already, I just couldn't remember what it was.
(In reply to Robert J. Wood [:rwood] from comment #3)
> Hey guys I am already working on this, see Bug 899194

I am sorry, but talos tp5 is not a good representative set of what Gaia apps are made of.
The problem raised here is not that we want exactly the same thing as AreWeSlimYet, but we want something which is capable of warning us when worker's size is increasing.  I don't think any of the tp5 has any worker.

Even if we can reuse the infrastructure of either AreWeSlimYet or AreWeFastYet, we at least need to find a benchmark which is focus on highlighting the features of the blocked bug / Gaia.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Whiteboard: [MemShrink:P1]

Comment 7

4 years ago
Hey all, sorry I will add more context to what I am currently working on for AWSY & Firefox OS.

No, we are not using the TP5 benchmarks. Instead of just testing the Firefox OS browser, we want to test all the gaia apps in order to ensure the main b2g process (at minimum) doesn't have a memory regression.

The test itself is an orangutan-based test that runs on the b2g emulator. The test drives the gaia-ui and simply starts each gaia app by tapping the app icon, leaves the app open for 10 seconds, and then presses the home button to minimize the app. Then it is repeated for each gaia app. The test will repeat for 6 hours. About_memory dumps will be taken at intervals and provided to AWSY.

The test will run on a per-CI basis using TBPL mozilla-central builds. We are setting up 4 amazon VMs to drive the automation via jenkins.

Regards,

Rob
(In reply to Robert J. Wood [:rwood] from comment #7)
> Hey all, sorry I will add more context to what I am currently working on for
> AWSY & Firefox OS.
> 
> No, we are not using the TP5 benchmarks. Instead of just testing the Firefox
> OS browser, we want to test all the gaia apps in order to ensure the main
> b2g process (at minimum) doesn't have a memory regression.

Ok, then this is indeed a duplicated bug.

> The test itself is an orangutan-based test that runs on the b2g emulator.

Orangutan-based?  Why choosing an interface which is so low level, this would be difficult to maintain when somebody adds a new icons to the home screen?
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 899194

Comment 9

4 years ago
(In reply to Nicolas B. Pierron [:nbp] from comment #8)
> (In reply to Robert J. Wood [:rwood] from comment #7)
> > Hey all, sorry I will add more context to what I am currently working on for
> > AWSY & Firefox OS.
> > 
> > No, we are not using the TP5 benchmarks. Instead of just testing the Firefox
> > OS browser, we want to test all the gaia apps in order to ensure the main
> > b2g process (at minimum) doesn't have a memory regression.
> 
> Ok, then this is indeed a duplicated bug.
> 
> > The test itself is an orangutan-based test that runs on the b2g emulator.
> 
> Orangutan-based?  Why choosing an interface which is so low level, this
> would be difficult to maintain when somebody adds a new icons to the home
> screen?

Hi, thanks Nicolas. We chose orangutan as we want to use a minimum amount of overhead as possible, and reduce the chance of having memory regressions caused by the automation itself. Yes true, however with other tools we would probably also need to update the test occasionally anyway according to gaia changes.

> 
> *** This bug has been marked as a duplicate of bug 899194 ***

Updated

4 years ago
No longer depends on: 931198
You need to log in before you can comment on or make changes to this bug.