Closed Bug 941825 Opened 7 years ago Closed 7 years ago

Intermittent robocop java-exception | java.util.NoSuchElementException at java.util.LinkedList.removeFirstImpl(LinkedList.java:689)

Categories

(Firefox for Android :: General, defect)

ARM
Android
defect
Not set
normal

Tracking

()

RESOLVED FIXED
Firefox 28
Tracking Status
firefox26 --- fixed
firefox27 --- fixed
firefox28 --- fixed
firefox-esr24 --- unaffected
b2g-v1.2 --- fixed

People

(Reporter: RyanVM, Assigned: lucasr)

References

Details

(Keywords: crash, intermittent-failure)

Attachments

(1 file)

https://tbpl.mozilla.org/php/getParsedLog.php?id=30906706&tree=Mozilla-Inbound

Android 4.0 Panda mozilla-inbound opt test robocop-1 on 2013-11-21 10:28:20 PST for push 3893c3542f07
slave: panda-0352

10:51:41     INFO -  27 INFO TEST-PASS | testBookmarkFolders | Folders do not have context menus - The context menu was not opened
10:51:41     INFO -  28 INFO TEST-PASS | testBookmarkFolders | waiting for urlbar text to gain focus - urlbar text gained focus
10:51:41     INFO -  29 INFO TEST-PASS | testBookmarkFolders | Trying to click on the Desktop Bookmarks folder - The Desktop Bookmarks folder was clicked
10:51:41     INFO -  30 INFO TEST-END | testBookmarkFolders | finished in 104010ms
10:51:41     INFO -  31 INFO TEST-START | Shutdown
10:51:41     INFO -  32 INFO Passed: 28
10:51:41     INFO -  33 INFO Failed: 0
10:51:41     INFO -  34 INFO Todo: 0
10:51:41     INFO -  35 INFO SimpleTest FINISHED
10:51:41     INFO -  INFO | automation.py | Application ran for: 0:01:48.191102
10:51:41     INFO -  INFO | zombiecheck | Reading PID log: /tmp/tmpWJqB1qpidlog
10:51:41     INFO -  /data/anr/traces.txt not found
10:51:41  WARNING -  PROCESS-CRASH | java-exception | java.util.NoSuchElementException at java.util.LinkedList.removeFirstImpl(LinkedList.java:689)
10:51:41     INFO -  WARNING | leakcheck | refcount logging is off, so leaks can't be detected!
10:51:41     INFO -  runtests.py | Running tests: end.
10:51:42     INFO -  Mochi-Remote ERROR | runTests() exited with code 1
Mark, can you help get some eyes on this? It's happening pretty frequently.
Flags: needinfo?(mark.finkle)
Try bisection and retriggers confirm that this is a regression from bug 989982. Looking at the changes in question, it sure looks believable to me.
Assignee: nobody → lucasr.at.mozilla
Blocks: 929982
Flags: needinfo?(mark.finkle) → needinfo?(lucasr.at.mozilla)
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #12)
> Try bisection and retriggers confirm that this is a regression from bug
> 989982. Looking at the changes in question, it sure looks believable to me.

s/bug 989982/bug 929982
(In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #13)
> (In reply to Ryan VanderMeulen [:RyanVM UTC-5] from comment #12)
> > Try bisection and retriggers confirm that this is a regression from bug
> > 989982. Looking at the changes in question, it sure looks believable to me.
> 
> s/bug 989982/bug 929982

Pushed a tentative patch to Try: https://tbpl.mozilla.org/?tree=Try&rev=294c5b663e84

I'll submit it or review if everything goes green.
Flags: needinfo?(lucasr.at.mozilla)
Comment on attachment 8337771 [details] [diff] [review]
Make BookmarksListAdapter's swapCursor() idempotent (r=mfinkle)

onLoadFinished() and, consequently, swapCursor() may get called twice with the same cursor. This patch makes our swapCursor() method a no-op if called with the same values again.
Attachment #8337771 - Flags: review?(mark.finkle)
Attachment #8337771 - Flags: review?(mark.finkle) → review+
https://hg.mozilla.org/mozilla-central/rev/bc69ab4c3a22

Please request approval to uplift to Aurora when you get a chance :)
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 28
Comment on attachment 8337771 [details] [diff] [review]
Make BookmarksListAdapter's swapCursor() idempotent (r=mfinkle)

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 929982
User impact if declined: Intermittent test failures and potential user-visible crasher.
Testing completed (on m-c, etc.): Pushed to try, all green. Local tests too.
Risk to taking this patch (and alternatives if risky): Fair low, just made a method idempotent.
String or IDL/UUID changes made by this patch: n/a
Attachment #8337771 - Flags: approval-mozilla-beta?
Attachment #8337771 - Flags: approval-mozilla-aurora?
Comment on attachment 8337771 [details] [diff] [review]
Make BookmarksListAdapter's swapCursor() idempotent (r=mfinkle)

taking this to go along with the uplift in bug 929982
Attachment #8337771 - Flags: approval-mozilla-beta?
Attachment #8337771 - Flags: approval-mozilla-beta+
Attachment #8337771 - Flags: approval-mozilla-aurora?
Attachment #8337771 - Flags: approval-mozilla-aurora+
You need to log in before you can comment on or make changes to this bug.