[B2G][Bluetooth] Users can open invalid file types by removing the extension.

RESOLVED WORKSFORME

Status

Firefox OS
General
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: RolandK, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun4)

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Created attachment 8336469 [details]
2013-11-21-15-26-43.png

Description:
If an invaild file type was sent without an extension, the user can open the file without an error message being displayed. 

Repro Steps:
1) Updated Buri to Build ID: 20131121004002
2) Pair the device with a laptop via Bluetooth.
3) Create a .pdf file, "Example.pdf"
4) Rename the file removing the extension, "Example".
5) Send the file via Bluetooth.
6) Attempt to open the file.

Actual:
User is able to open the invalid file type and a blank-black screen is displayed.

Expected:
A user receiving a file type not valid to the device and attempting to open it provides a valid error message.

Environmental Variables
Device: Buri v1.2 COM RIL
Build ID: 20131121004002
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/36c4c667b9f2
Gaia: ce276842c9ac1746073271fb736dfdb626a89240
Platform Version: 26.0
RIL Version: 01.02.00.019.102 
Firmware Version: V1.2_US_20131115

Notes: This issue does not repro on the previous base image: US_20131104.

Repro frequency: 100%
Test Suite Name: Bluetooth
Link to failed test case: https://moztrap.mozilla.org/manage/cases/?filter-id=8906#caseversion-id-80780

See attached: 2013-11-21-15-26-43.png
According to the description, the file was completely received via Bluetooth. The problem was that it shouldn't launch any app when the user attempted to open the file (by clicking the 'file received' notification in notification center, I guess). Therefore I'm going to reset this issue to another component (not sure which component should be set so I tried 'General' first).
Component: Bluetooth → General
QA Wanted - what app is getting launched here when you try to open the file? You can see this by opening the task manager from the app.
Keywords: qawanted
(Reporter)

Comment 3

5 years ago
The gallery app is being launched when the file is opened. This issue does not reproduce on the latest build: 20131122004001.
Keywords: qawanted

Updated

5 years ago
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.