[b2g] auto suggestion uses truncated/shortend words

VERIFIED FIXED in Firefox OS v1.2

Status

Firefox OS
Gaia::Keyboard
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: mad_maks, Assigned: rudyl)

Tracking

unspecified
1.2 C6(Dec6)
x86_64
Linux

Firefox Tracking Flags

(blocking-b2g:koi+, b2g-v1.2 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Description: If you type a long word witch can have multiple suggestions, the suggestions get shortend with dots in the middle to fit on the screen. if you select a word with dots it will not use the suggested word but the shortend one with the dots

Repro Steps: 
1) Set the keyboard to dutch/nederlands (i think every language will do but i tested it in dutch 
2) turn word suggestion on 
3) compose a sms
4) type "afstandsb". 
5) select suggestion "Afstan...iening".  

Actual: composer uses Afstan...iening.

Expected: composer uses Afstandsbediening. 

Environmental Variables 
Device: Geeksphone Keon
Build ID: 20131120224415
Can you reproduce this on 1.2?
Flags: needinfo?(bugzilla)
(Reporter)

Comment 2

4 years ago
sorry dit not mention the version: 1.2.0.0 prerelease
Flags: needinfo?(bugzilla)
Nominating koi? as this is a clear regression from 1.1.

David, just ni? you here to ping.
blocking-b2g: --- → koi?
Flags: needinfo?(dflanagan)
Tim,

Please see if your team can take this bug?
Flags: needinfo?(timdream)

Updated

4 years ago
blocking-b2g: koi? → koi+
Rudy, can this cut in line of your working queue? djf is unfortunately on PTO...
Assignee: nobody → rlu
Flags: needinfo?(timdream) → needinfo?(rlu)
Yes, will take a look.
Status: NEW → ASSIGNED
Flags: needinfo?(rlu)
Flags: needinfo?(dflanagan)
Target Milestone: --- → 1.2 C6(Dec6)
Created attachment 8340918 [details] [review]
Patch V1

[Root Cause]
In the following commit, we changed the interface for inputMethod.select() function,
https://github.com/mozilla-b2g/gaia/commit/252eeba4ffed9acd3aaf8ac56f540a7ae708f788

We should pass the data for the full word as the 2nd parameter to latin inputMethod.


Tim,

Could you please review this patch?
Thanks.
Attachment #8340918 - Flags: review?(timdream)
Comment on attachment 8340918 [details] [review]
Patch V1

Thanks!!
Attachment #8340918 - Flags: review?(timdream) → review+
Landed to Gaia msster,
https://github.com/mozilla-b2g/gaia/commit/38bb3f608bafeda965274abfe941678197e2da2a

--
Tim thanks for the review.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
status-b2g-v1.2: --- → affected
Resolution: --- → FIXED
Gaia v1.2,
https://github.com/mozilla-b2g/gaia/commit/c8f14ad3950d59ba13d7639eff02d080060bb3ce
status-b2g-v1.2: affected → fixed
Duplicate of this bug: 945910
(Reporter)

Comment 12

4 years ago
Gaia 1.2 build 20131203224512 

Thanks for the quick fix!
Status: RESOLVED → VERIFIED
Selecting suggested words with ellipses in them, such as Misint...tation, will result in the entire word being displayed. Verified as fixed for latest 1.2 and 1.3 builds.

1.2 Environmental Variables:
Device: Buri v1.2 COM RIL
BuildID: 20131204004003
Gecko: http://hg.mozilla.org/releases/mozilla-b2g26_v1_2/rev/244e98241b2c
Gaia: c8f14ad3950d59ba13d7639eff02d080060bb3ce
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: V1.2_20131115

1.3 Environmental Variables
Device: Buri v1.3 Mozilla RIL
Build ID: 20131203040236
Gecko: http://hg.mozilla.org/mozilla-central/rev/8648aa476eef
Gaia: 31808a29cfcffa584b6a88b4f1e515387f485a1b
Platform Version: 28.0a1
Firmware Version: v1.2_20131115
status-b2g-v1.2: fixed → verified
You need to log in before you can comment on or make changes to this bug.