360p max resolution for WebM HTML5 Videos on Youtube

RESOLVED DUPLICATE of bug 1043696

Status

()

defect
RESOLVED DUPLICATE of bug 1043696
6 years ago
3 years ago

People

(Reporter: Elio, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox32 affected, firefox33 affected, firefox34 affected, firefox35- affected, firefox36 affected)

Details

(Whiteboard: [testday-20131122], URL)

Attachments

(2 attachments)

(Reporter)

Description

6 years ago
Cuirrently it's not possible to play HTML5 Videos from Youtube on Firefox with a resolution over 360p.
Seems Firefox doesn't support too many codecs (due to proprietary patents also, right?) as one can see in the attached picture, while Chrome supports all codecs and can play all videos in all resolutions available in HTML5.

What are the plans regarding HD HTML5 videos from Youtube?
(Reporter)

Updated

6 years ago
(Reporter)

Comment 1

6 years ago
Chrome has support for all codecs for HMTL5 videos on Youtube

Comment 2

6 years ago
H.264 is supported in systems that have the codec, Windows XP is not one of those systems. 

Resolutions should not be a difference between firefox and chrome as long as the site doesn't do ua sniffing.

The second line in youtubes html5 page is about DRM and can't be supported by open source by definition.

Comment 3

6 years ago
It's probably closer to Tech Evangelism than to Firefox.
OS: Windows XP → All
Summary: 360p max resolution for HTML5 Videos on Youtube → 360p max resolution for WebM HTML5 Videos on Youtube
Whiteboard: [testday-20131122]

Updated

6 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 799318

Updated

6 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Updated

6 years ago
Blocks: 799318

Comment 5

6 years ago
Given that H.264 support is available in Firefox 26 and that Chrome does see the codec in the system, this should work.

Moving to a more appropriate component. Perhaps someone there knows more about what could be happening here.
Component: Untriaged → Video/Audio
Product: Firefox → Core
Google knows about Firefox ongoing progress on implementing MSE (Bug 778617 and friends).

nevertheless they seem to UA sniff Firefox out for reducing the resolution choice willfully - I wonder why they don't use UA sniffing on non-yet-MSE browsers giving them and their users the full choice as a status quo.

e.g. they provide a WebP fallback on their sites as well. flash usage cannot be it on this matter.

thus, it must be an evil google product choice :P
No longer blocks: 799318
Keywords: html5
This bug is reproducible only on Mac Os X.
I managed to reproduce this on:

FF 32 Nightly
Build Id: 20140515030202

the bug is reproducible even on FF 4 so this is not a regression.
This is the video used to reproduce the issue http://www.youtube.com/watch?v=kkGeOWYOFoA .
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: All → Mac OS X
Hardware: x86 → All
Version: unspecified → Trunk
Severity: major → normal
Depends on: 1000686
OS: Mac OS X → All
As described by comment #6, this is because youtube has stopped serving HD WebM to the html5 player. My understanding is that they plan to offer HD again through MediaSource Extensions. They are currently doing so for Chrome.

If I enable our experimental MediaSource Extensions support in Firefox Nightly, I can select up to 720p video from the gear menu in the video from comment #8, but it seems to select 240p by default.

You won't see this issue if you have flash installed, and maybe not if Firefox supports h.264 on your platform. VarCar, do you have flash installed for your reproduction on MacOS X?
Flags: needinfo?(catalin.varga)
(In reply to Ralph Giles (:rillian) from comment #9)
> If I enable our experimental MediaSource Extensions support in Firefox
> Nightly, I can select up to 720p video from the gear menu in the video from
> comment #8, but it seems to select 240p by default.

This may be because of bug 77992, our DOM event timestamps are in the wrong base, so rate estimation is doesn't work properly.
(In reply to Ralph Giles (:rillian) from comment #9)
> As described by comment #6, this is because youtube has stopped serving HD
> WebM to the html5 player. My understanding is that they plan to offer HD
> again through MediaSource Extensions. They are currently doing so for Chrome.
> 
> If I enable our experimental MediaSource Extensions support in Firefox
> Nightly, I can select up to 720p video from the gear menu in the video from
> comment #8, but it seems to select 240p by default.
> 
> You won't see this issue if you have flash installed, and maybe not if
> Firefox supports h.264 on your platform. VarCar, do you have flash installed
> for your reproduction on MacOS X?

I have flash installed on my mac, this is the information from about:plugins :
Shockwave Flash

    File: Flash Player.plugin
    Path: /Library/Internet Plug-Ins/Flash Player.plugin
    Version: 14.0.0.101
    State: Enabled
    Shockwave Flash 14.0 d0
Flags: needinfo?(catalin.varga)
This bug is also reproducible on:

FF 31.0b5
Build Id:20140626181429
OS: Ubuntu 14.04 x32
Add-on for H.264 playback says "Will be installed shortly" for Firefox Nightly 33.0a1 (2014-07-18)

Maybe that's why it only shows resolutions up to 360p?

Screenshot for add-on:
http://i.imgur.com/c8XymGf.png

Youtube compatibility:
http://i.imgur.com/vOFcHuw.png
My system is Ubuntu 14.04 (complementing comment #13)
Duplicate of this bug: 1050015
Still happening in Firefox 35 nightly.

Updated

5 years ago
See Also: → 1055516

Updated

5 years ago
Duplicate of this bug: 1055516
Issue still reproducible in 34 beta 10 (Build ID: 20141117202603) on Mac OS X 10.9.5 and Ubuntu 14.04 64-bit using link: http://www.youtube.com/watch?v=kkGeOWYOFoA. Did not reproduce on Windows 7 or 8.
[Tracking Requested - why for this release]:

Too late to fix this for 34 but it seems possibly important to track for 35.

Comment 20

4 years ago
seems fixed in today's nightly, even until 4k
This was found a long time ago and nothing suggests a new volume of concern about this issue.  Yes, it should be fixed and we could consider a low-risk uplift if one is identified and nominated before Dec 22 for inclusion in the next beta, otherwise it should ride the trains.
Yes. This particular issue will be fixed when mac mp4 playback or MSE support rides the trains to release. Likely the former in Firefox 35.
In fact, let's treat it as such.
Status: NEW → RESOLVED
Last Resolved: 6 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1043696

Comment 24

4 years ago
I don't understand. This bug has been marked as a duplicate of a Mac OS X specific bug. But Linux is affected too!
(In reply to Vincent Lefevre from comment #24)
> I don't understand. This bug has been marked as a duplicate of a Mac OS X
> specific bug. But Linux is affected too!

Apologies, I wasn't thinking about Linux. This won't be resolved for Windows XP or Linux systems without licensed gstreamer elements for mp4 playback until we ship MSE support for WebM, probably in Firefox 37 or 38. However most Windows XP users have flash installed and can use that as a fallback.
Does this mean you got fallback to non-MSE webm on Windows XP with 36 beta 1? We had one report of that and would like to clarify.

Right-click on the youtube video and select 'Stats for nerds' from the popup menu.

Look for DASH: yes -> video is using MSE
         DASH: no  -> video is not using MSE

Look for 'vp9, vp8 or webm' -> video is webm
      or 'avc, mp4'         -> video is mp4

These are important when reporting youtube issues so we know which playback path was used.
Flags: needinfo?(florin.mezei)
I should add, if the right-click menu says something about 'Flash Player' YouTube has served flash video instead of HTML, which is the fifth playback path, and equally relevant.
Used the youtube link from the comments above https://www.youtube.com/watch?v=kkGeOWYOFoA
Right click context menu does say "About the HTML5 player"
You can see below the results on multiple platforms and operating systems.

Firefox 36beta1:

Windows 10
Mime Type: video/mp4; codecs="avc1.4d401e"
DASH: yes (135/140)
- Does show 720p

Windows 7
Mime Type: video/mp4; codecs="avc1.4d401e"
DASH: yes (136/140)
- Does show 720p

Mac OS X 10.9.5
Mime Type: video/mp4; codecs="avc1.42001E, mp4a.40.2"
DASH: no (18)
- Does show 720p

Ubuntu 14.04 32bit
Mime Type: video/webm; codecs="vp8.0, vorbis"
DASH: no (43)
- Does not show 720p

Windows XP 32bit
Mime Type: video/webm; codecs="vp8.0, vorbis"
DASH: no (43)
- Does not show 720p

Chrome:

Mime Type: video/webm; codecs="vp9"
DASH: yes (244/140)
- Does show 720p
Flags: needinfo?(florin.mezei)

Comment 29

4 years ago
I enjoyed YT last year but recently it has been a pain. I have become fairly expert in attempting to get FF to show Videos with as many "Menu Features" as possible. I had the problem with FF 38.0a2 (2015-03-06) but this works for the other FFs too.


Install Add-on Compatibility Reporter from: https://addons.mozilla.org/en-us/firefox/addon/add-on-compatibility-reporter/ and Random Agent Spoofer from: https://addons.mozilla.org/en-us/firefox/addon/random-agent-spoofer/ .

Use 'RAS' to choose "Arora 0.8.0 - Win32" to spoof, in order to view 3D Videos with Anaglyph Glasses, and use this 'About Config' Setting to set the value to FALSE. Works (for this week).


about:config

media.mediasource.enabled
Bogdan, can you file a separate bug for the Linux issue? Thanks!
Flags: needinfo?(bogdan.maris)
(In reply to Liz Henry (:lizzard) from comment #30)
> Bogdan, can you file a separate bug for the Linux issue? Thanks!

I don`t think we should log a bug on Linux based on Ralphs statement from comment 25.
Flags: needinfo?(bogdan.maris)

Comment 32

4 years ago
(In reply to Bogdan Maris, QA [:bogdan_maris] from comment #31)
> (In reply to Liz Henry (:lizzard) from comment #30)
> > Bogdan, can you file a separate bug for the Linux issue? Thanks!
> 
> I don`t think we should log a bug on Linux based on Ralphs statement from
> comment 25.

I don't understand. The problem still occurs under Linux and will apparently be solved in the near future (Comment 25 says maybe FF 37 or 38). A bug would help to see what's going on and in which version it will be fixed.

Updated

3 years ago
See Also: → 1229260
You need to log in before you can comment on or make changes to this bug.