Mach error on Ubuntu: "ValueError: Expecting property name"

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
10 months ago

People

(Reporter: marco, Unassigned)

Tracking

Trunk
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
The trace is:

  File "./mach", line 55, in <module>
    main(sys.argv)
  File "./mach", line 30, in main
    info = json.load(open(mozinfo_path))
  File "/usr/lib/python2.7/json/__init__.py", line 290, in load
    **kw)
  File "/usr/lib/python2.7/json/__init__.py", line 338, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python2.7/json/decoder.py", line 365, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python2.7/json/decoder.py", line 381, in raw_decode
    obj, end = self.scan_once(s, idx)
ValueError: Expecting property name: line 1 column 2 (char 1)
I'm guessing something wonky happened during the build. Abort during file write, perhaps?

Can you reliably reproduce this? If not, I'm tempted to WORKSFORME.
Flags: needinfo?(mar.castelluccio)
(Reporter)

Comment 2

5 years ago
(In reply to Gregory Szorc [:gps] (in southeast Asia until Dec 14) from comment #1)
> I'm guessing something wonky happened during the build. Abort during file
> write, perhaps?
> 
> Can you reliably reproduce this? If not, I'm tempted to WORKSFORME.

It was the first time I was trying to use mach on this machine. I did clobber before attempting to build.

The problem was the mozinfo.json file in the top level source directory.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Flags: needinfo?(mar.castelluccio)
Resolution: --- → WORKSFORME

Updated

10 months ago
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.