Closed Bug 942193 Opened 7 years ago Closed 7 years ago

Build bustage in non-unified mode in layout/style

Categories

(Core :: CSS Parsing and Computation, defect)

x86
macOS
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 942137

People

(Reporter: ehsan, Assigned: ehsan)

References

Details

Attachments

(1 file)

glandium reported this bug on dev.platform!

A build with unified sources disabled already
fails:

layout/style/nsStyleUtil.h:62:12: error: member access into incomplete
type 'nsAString_internal'
    aResult.AppendFloat(aNumber);
            ^
../../dist/include/nsXPCOM.h:20:12: note: forward declaration
of 'nsAString_internal'
DECL_CLASS(nsAString);
Blocks: unified
Blocks: 932102
Bug 932102 broke this.
Attached patch Patch (v1)Splinter Review
Attachment #8336853 - Flags: review?(dholbert)
The necessary patch is already r+'d in bug 942137.
Status: NEW → RESOLVED
Closed: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942137
Attachment #8336853 - Flags: review?(dholbert)
You need to log in before you can comment on or make changes to this bug.