pdf viewer pdf.js - wrong characters and gray boxes where there should be images

VERIFIED FIXED in Firefox 29

Status

()

P3
normal
VERIFIED FIXED
5 years ago
5 years ago

People

(Reporter: guillaume.criloux, Unassigned)

Tracking

27 Branch
Firefox 29
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161)

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8336862 [details]
pdfissues.jpg

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:27.0) Gecko/20100101 Firefox/27.0 (Beta/Release)
Build ID: 20131120004002

Steps to reproduce:

Open following PDF file in internal viewer of Firefox 27.0a2: http://www.satsentinel.org/sites/default/files/reports/Expanding-War-in-Sudan-Threatens-Civilians.pdf



Actual results:

All pages: at the bottom, the footer is mangled.
On pages with images (p. 5 and following), grey boxes appear next to graphics overlaid on an image, where the image should be seen (transparency issue ?).

On the attached file, the footer issue is seen at the top, and the image at the center.


Expected results:

All pages: footer should be clear
Pages with images: underlying image should be visible instead of grey boxes.
(Reporter)

Updated

5 years ago
Component: Untriaged → PDF Viewer

Comment 1

5 years ago
Created attachment 8337124 [details]
Expanding-War-in-Sudan-Threatens-Civilians_4_5.pdf

Comment 2

5 years ago
In the sample I attached (pages 4 to 5), I see only the issue about the images (gray squares) with FF25, 27 and 28. It's a known issue about Smask feature unimplemented (and already reported).

But I'm not able to reproduce the issue about the text rendering in the footer.

Could you test the PDF sample with a fresh profile, please.
https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-firefox-profiles
Flags: needinfo?(guillaume.criloux)
"Warning: TODO: graphic state operator SMask"
(Reporter)

Comment 4

5 years ago
> But I'm not able to reproduce the issue about the text rendering in the
> footer.
> 
> Could you test the PDF sample with a fresh profile, please.
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

Works for me on another profile (FF 27a on Win 8). I don't have access to the same box I first noticed the footer issue until Monday.
Flags: needinfo?(guillaume.criloux)
(Reporter)

Comment 5

5 years ago
> But I'm not able to reproduce the issue about the text rendering in the
> footer.
> 
> Could you test the PDF sample with a fresh profile, please.
> https://support.mozilla.org/en-US/kb/profile-manager-create-and-remove-
> firefox-profiles

Just tested on the same configuration on which I initially reported the issue. I still see the text garbled using a fresh profile, both with the original PDF and the shorter one built by Loic. I don't know what is specific to that configuration that triggers the issue.
Priority: -- → P3
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask]
Mozilla/5.0 (Windows NT 6.0; rv:28.0) Gecko/20100101 Firefox/28.0
Reproduced the rendering text in the footer on latest Nightly build (20131204030203) on a Vista machine with DirectWrite 7.0.6002.23200.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: [pdfjs-c-rendering][pdfjs-d-smask] → [pdfjs-c-rendering][pdfjs-d-smask][pdfjs-f-fixed-upstream] https://github.com/mozilla/pdf.js/pull/4161
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Depends on: 965861
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.