Folder list scrolling seems broken

RESOLVED FIXED in Firefox 28

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: ladamski, Assigned: fabrice)

Tracking

({regression})

unspecified
1.3 Sprint 5 - 11/22
x86
Mac OS X
regression

Firefox Tracking Flags

(blocking-b2g:koi+, firefox26 wontfix, firefox27 wontfix, firefox28 fixed, b2g-v1.2 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
Trying as hard as I can, I can only get the folder list to scroll by 1-2 pixels at a time.
(Reporter)

Comment 1

5 years ago
Peak 1.2 build, latest nightly.
blocking-b2g: --- → koi?
Keywords: regression
This seems global with last night's nightly: I noticed it in the Settings app too.
Keywords: regressionwindow-wanted
Maybe something got uplifted to v1.2 recently?  We were seeing something like this on master in Brussels/summit on a nexus 4 I think and my general hope had been that there was just a regression someone would fix.  Brief discussion in #gaia was that we probably have iframes that are eating most of the scroll event, leaving us with only a few pixels of scroll.  (It sounded like this was buggy distribution of the scroll events, though, since we really only have one iframe that should be doing stuff.)  My most recent hope would be that our drawer overhaul for v1.3 would just fix/workaround this.  But if it's somehow gotten to v1.2, that's very bad.
(Reporter)

Comment 4

5 years ago
Tragedy of the commons. :)  Please file all bugs you see, esp. on master so we can catch these before they uplift.

Comment 5

5 years ago
Lucas, 

Could you please provide STR and environmental variables (gecko,gaia,build ID and device)? If we can get those, we can find a regression window. 

Thanks!
Flags: needinfo?(ladamski)
(Reporter)

Comment 6

5 years ago
To expand on comment 1, peak 1.2 build id 20131121205355 (geeksphone daily builds), git 2013-11-21.  Sounds like it dates back to at least early Oct on central per comment 3.

STR:
open email app, try to scroll folder list.
Flags: needinfo?(ladamski)
(Assignee)

Comment 7

5 years ago
That may be a regression from Bug 914854 that landed Oct 1. I can't repro on my helix, I'll check on a 320x480 device asap.
(Assignee)

Comment 8

5 years ago
Created attachment 8337347 [details] [diff] [review]
panning.patch

That fixes the issue for me.
Assignee: nobody → fabrice
Attachment #8337347 - Flags: review?(21)
Keywords: regressionwindow-wanted
Component: Gaia::E-Mail → General
This was merged and the bug never marked.

https://hg.mozilla.org/mozilla-central/rev/fbafab3a0c28
Status: NEW → RESOLVED
Last Resolved: 5 years ago
status-b2g-v1.2: --- → affected
status-firefox26: --- → wontfix
status-firefox27: --- → wontfix
status-firefox28: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → 1.3 Sprint 5 - 11/22
(Assignee)

Updated

5 years ago
blocking-b2g: koi? → koi+
You need to log in before you can comment on or make changes to this bug.