GitHub Notifications show up as if they are all from the same person

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: ajf, Unassigned)

Tracking

24 Branch
x86_64
Linux

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131115105349

Steps to reproduce:

I received notifications from notifications@github.com. GitHub sends all notifications from that address, but sets a different name for the sender depending on who made the comment.


Actual results:

All GitHub notifications show up as being from the first person I got a notification from. Deleing the "Collected Contact" simply means a different person will show up.


Expected results:

Thunderbird should have shown the name GitHub specified in the email headers, or at least allowed me to not show the name of the Collected Contact here.

Comment 1

5 years ago
You could uncheck "Show only display name for people in my address book" in Edit > Preferences > Advanced > Reading & Display, at the bottom of that panel. That should show the full address as sent.

Comment 2

5 years ago
Just go into the address book entry for notifications@github.com and uncheck "Always prefer display name over message header".

Comment 3

5 years ago
That was actually the option that I was looking for, but I thought it was hiding in the preferences. :-) Either of those will hopefully do the trick.

Comment 4

5 years ago
(In reply to rsx11m from comment #3)
> That was actually the option that I was looking for, but I thought it was
> hiding in the preferences. :-) Either of those will hopefully do the trick.

Yeah, it's a per-contact thing. It should only be turned on by default if you manually create the address book entry; when it's added automatically to the Collected Addresses list, the option is turned off for exactly the reason in this bug.

Comment 5

5 years ago
Resolving, since there's nothing to do here. If something doesn't work right, feel free to reopen this.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.