[Marketplace] Network connection unavailable while trying to connect to marketplace

RESOLVED FIXED

Status

Marketplace
General
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: marcia, Unassigned)

Tracking

({regression})

Avenir
ARM
Gonk (Firefox OS)
regression
Points:
---

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
Buri, while running:

Gaia   2cc78d696482e0434b584f5645af55e3105e59a2
SourceStamp 3c4fc4279e6a
BuildID 20131122123502
Version 28.0a1
Base image: 11-15

STR:
1. Launch Marketplace with a network connection
2. Observe screenshot here: http://imgur.com/EafnJkP

Natalya captured a logcat - can you please attach it when you get back

I reset my device after this happened and I have not seen the issue since.
(Reporter)

Comment 1

4 years ago
Created attachment 8337027 [details]
Logcat while trying to launch mplace with data connection

Better set of STR:

1. Freshly flashed device
2. Turn on wifi and launch marketplace -> launches
3. Turn off wifi and turn on data connection and launch marketplace -> receive error in first attachment.
This might be a fallout from the work done in bug 882186.

Mike - Can you take a look into this?
blocking-b2g: --- → 1.3?
Component: Gaia::System → Gaia::System::Window Mgmt
Flags: needinfo?(mhenretty)
Keywords: regression, regressionwindow-wanted
Whiteboard: [systemsfe]

Updated

4 years ago
QA Contact: sparsons

Comment 3

4 years ago
Created attachment 8337042 [details]
logcat

thought this logcat might be helpful too, even thought i eventually launched marketplace here
I flashed gaia master (d1bea46121987a35501521ef1d1d5971b137dbdf) on a Leo (build 20131118182014), and marketplace launches. I can turn also turn on wifi, launch marketplace, see the screen from the attachment, backgroung the app, turn on wifi, go to the marketplace, push retry button, and marketplace will load.

It's possible this is a Buri specific issue, or possible that the data connection on Marcia's phone is timing out when connecting to the marketplace.

In either case, I'm investigating.

Also, the "Close" button does not work on the marketplace in offline mode. Filing a separate bug for that shortly.
Assignee: nobody → mhenretty
Flags: needinfo?(mhenretty)
Looks like it's a certificate error with marketplace. Not sure why we would see this intermittently though:


11-22 11:51:28.319: E/GeckoConsole(137): [JavaScript Error: "An error occurred during a connection to marketplace.firefox.com:443.
11-22 11:51:28.319: E/GeckoConsole(137): SSL received a malformed Server Key Exchange handshake message.
11-22 11:51:28.319: E/GeckoConsole(137): (Error code: ssl_error_rx_malformed_server_key_exch)
11-22 11:51:28.319: E/GeckoConsole(137): "]
(Reporter)

Comment 6

4 years ago
I was able to reproduce this again even after resetting the device. Some other data points mentioned in the #gaia channel:

*The try and close button do nothing when I press them when this happens with Marketplace
*I don't have an extremely strong signal where I am testing today. 
*During the first round of testing I was only getting this error with marketplace, but now it is happening with browser as well.
*After restarting the device with a data connection, marketplace does launch.

So this is definitely an intermittent issue that is not 100% reproducible at this point.

How do we turn on data logging to see what is going on there?
Hm maybe this is a marketplace problem? I couldn't open the marketplace on my 1.0.1 phone from ebay today.
(In reply to Gregor Wagner [:gwagner] from comment #7)
> Hm maybe this is a marketplace problem? I couldn't open the marketplace on
> my 1.0.1 phone from ebay today.

There is definitely at least a certificate error with the marketplace as seen in Naoki's logcat. Gregor, do you know whom I can contact about that?

I also think Marcia's cell data connection is spotty, which is why she sometimes see the offline error screen even in the browser. I think that's a separate (but confusing/conflating) issue from the marketplace certificate error.

The "Close" button not working in marketplace offline screen is a flat out bug which I can reproduce consistently. I have filed that here: bug 942325.
Talked with cvan in person about this - this was a marketplace prod regression which should be fixed now.
Assignee: mhenretty → nobody
Status: NEW → RESOLVED
blocking-b2g: 1.3? → ---
Last Resolved: 4 years ago
Component: Gaia::System::Window Mgmt → General
Keywords: regressionwindow-wanted
Product: Firefox OS → Marketplace
Resolution: --- → FIXED
Whiteboard: [systemsfe]
Version: unspecified → Avenir
You need to log in before you can comment on or make changes to this bug.