[B2G][Dialer] Empty call log for Missed Calls tab does not have proper message

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
5 years ago
4 years ago

People

(Reporter: nkhristoforov, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g18 unaffected, b2g-v1.2 affected)

Details

(Whiteboard: burirun4)

Attachments

(3 attachments)

(Reporter)

Description

5 years ago
Created attachment 8337091 [details]
Error Screenshot

When the user deletes all of the entries in the Missed Calls tab in the Call Log, the call log retains the format where the headers like "Today" and "Yesterday" are present but empty. An empty Missed Calls log would have a message saying there are no missed calls. 

Repro Steps:
1) Updated Buri to BuildID: 20131122004001
2) Call the test device from another device but don't answer to get a missed call.
3) Open the Dialer app.
4) Select the Call Logs button in the bottom-left corner.
5) Open the Missed Calls tab.
6) Select the Edit botton in the top-right corner.
7) Select the Select All button.
8) Select the Delete button and press OK. 
9) Verify the page retains the header format and does not show the empty page message

Actual:
The header format remains and there's no empty page message.

Expected:
The empty page message would be displayed on the page since there are no missed call logs.

Environmental Variables:
Device: Buri v1.2 Com RIL
BuildID: 20131122004001
Gaia: 7b24f1d1f167fc40b1e887f4ff3746d383af3c2f
Gecko: 866496ed1f26
Version: 26.0
Firmware Version: V1.2_20131115

Repro frequency: 100%
Link to failed test case: https://moztrap.mozilla.org/manage/case/2265/
See attached: Screenshot
(Reporter)

Comment 1

5 years ago
Created attachment 8337092 [details]
Right Screenshot
(Reporter)

Comment 2

5 years ago
This bug does not reproduce on the 1.1 build. After deleting all the missed call logs, the proper empty page message appears.

Device: Leo v1.1 MOZ RIL
BuildID: 20131030041204
Gaia: 39b0203fa9809052c8c4d4332fef03bbaf0426fc
Gecko: 41c15ddb7216
Version: 18.0
status-b2g18: --- → unaffected
status-b2g-v1.2: --- → affected
Keywords: regression, regressionwindow-wanted
(Reporter)

Comment 3

5 years ago
Additional Notes: The call log has to be populated with outgoing calls or incoming calls. If the call log only has missed calls, then after deleting all of the missed call logs in the Missed Calls tab the empty page would show the empty page message for the All Calls tab (Other Error Screenshot).
(Reporter)

Comment 4

5 years ago
Created attachment 8337108 [details]
Other Error Screenshot
This is a disappointing UX regression that we should fix, but we probably can't block on this at this point.

Somebody should look into fixing this, however.

Updated

5 years ago
QA Contact: sarsenyev

Comment 6

5 years ago
There is no regression window for this issue, the regression begins  from June 21st when the first  1.2 Master build was released and reproduces on all 1.2 builds

Device: Buri 1.2 Master build
BuildID: 20130621031231
Gaia: e2f19420fa6a26c4287588701efaec09a750dba1
Gecko: 7ba8c86f1a56
Version: 24.0a1
Firmware version: V1.2_US_20131115
Keywords: regressionwindow-wanted
QA Contact: sarsenyev
Can someone double check if this happens on 1.1?
Keywords: qawanted

Comment 8

5 years ago
It doesn't reproduce on 1.1 on Leo and Buri devices,
The message is displayed correctly on both devices

Updated

5 years ago
Keywords: qawanted
We are unable to repro this anymore.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.