Greek keyboard name is untranslated

RESOLVED FIXED

Status

Firefox OS
Gaia::Keyboard
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: alefteris, Assigned: alefteris)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v1.2 fixed, b2g-v1.3 fixed)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Created attachment 8337384 [details]
Keyboard layouts list

Greek keyboard name is untranslated.

Tested with images-keon-v1.2-2013-11-23.Gecko-b9f0351.Gaia-5a0802f
(Assignee)

Comment 1

4 years ago
Created attachment 8337388 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13975

Pointer to Github pull-request
(Assignee)

Updated

4 years ago
Attachment #8337388 - Flags: review?(rlu)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Assigned to Alfredos for he got a patch. :)
Assignee: nobody → alefteris
Status: NEW → ASSIGNED
Sorry, correct myself in Comment 2, it should be Thanos to be the assignee.
Comment on attachment 8337388 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13975

As commented on the pull request, I found on wikipedia or Android phone, it used ελληνικά for "Greek" in the context of language.
Could you help us understand this difference?

--
Clear the review flag first, so I'll be notified after you flag me again for the review.
Thanks.
Attachment #8337388 - Flags: review?(rlu)
"Ελληνικά" (plural form) means "Greek" and it implies the phrase "Greek language".

As this is about keyboard, we use in greek the singular form of this word "Ελληνικό".

I don't know if this is possible but it would be great if we can land this fix on v1-train and v1.2 branches too.

Thanks
Attachment #8337388 - Flags: review?(rlu)
Comment on attachment 8337388 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13975

r=me.

Thank you for the patch and the clarification.
Attachment #8337388 - Flags: review?(rlu) → review+
Merged to Gaia master,
https://github.com/mozilla-b2g/gaia/commit/0904f366263eca59f61afb9c340004f91e488870
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8337388 [details]
Pointer to Github pull request: https://github.com/mozilla-b2g/gaia/pull/13975

I guess it is too late to land any changes to v1-train, so let's try to get this into v1.2.

-----------------------
NOTE: Please see https://wiki.mozilla.org/Release_Management/B2G_Landing to better understand the B2G approval process and landings.

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): n/a.
[User impact] if declined: Greek Keyboard name not shown in native language.
[Testing completed]: Yes, manually.
[Risk to taking this patch] (and alternatives if risky): low, just string change, and not related to l10n, we would show all layout names in its native language.
[String changes made]: As above.
Attachment #8337388 - Flags: approval-gaia-v1.2?(timdream)
Attachment #8337388 - Flags: approval-gaia-v1.2?(timdream) → approval-gaia-v1.2+
Uplifted to v1.2 with Tim's approval,
https://github.com/mozilla-b2g/gaia/commit/cfca0f96668c56e7c523c2ac8db1701e98e324e6

Thanks.
status-b2g-v1.2: --- → fixed
status-b2g-v1.3: --- → fixed
You need to log in before you can comment on or make changes to this bug.