[B2G][Helix][Performance][chengchangying]The response time of the key is too long.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Music
P2
normal
RESOLVED WONTFIX
5 years ago
4 years ago

People

(Reporter: lecky, Unassigned)

Tracking

({perf})

unspecified
1.3 C1/1.4 S1(20dec)

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [c=effect p= s=2013.12.20 u=])

(Reporter)

Description

5 years ago
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; aff-kingsoft-ciba; Tablet PC 2.0; .NET4.0C; .NET4.0E)

Steps to reproduce:

Steps to reproduce:
  
   Prebuild condition:1000 pictures,200 videos and 164 muisic are stored in the external SD.

1、play a video in  the external SD,and click the "fast forward" key and then click the "fast backward" key;

2、record the response time of  the "fast forward" key  and the "fast backward" key;

3、play a music in the  the external SD,and click the "next" key;

4、record the response time of  the "play" key  and the "next" key;





Actual results:

Comparison results:
                               V1.1                            V1.0
music             fast forward:567ms          fast forward:225ms
                     fsat backward:433ms        fsat backward:316ms 

video              play:1576ms                     play:1165ms
                     next:500ms                      next:327

acatual resluts:The performance in v1.1 is more bad than it is in v1.0.



Expected results:


   The response time of the keys in v1.1  is more shortter than it is in v1.0.
(Reporter)

Updated

5 years ago
Component: General → Gaia::Music
Priority: -- → P2

Comment 1

5 years ago
Lecky, please retest this against 1.2 and post your findings as you did in comment 0.

Thanks,
FxOS Perf Triage
Flags: needinfo?(lecky.wanglei)
Keywords: perf
Whiteboard: [c=effect p= s= u=]
(Reporter)

Comment 2

5 years ago
Hi, Mike,


    We only want to improve the performance in build v1.1.

Updated

5 years ago
Flags: needinfo?(lecky.wanglei)

Comment 3

5 years ago
For music app, fast-forward/rewind were not supported until bug 897882 was landed, it's a v1.2 feature to support AVRCP so I think we are not talking about fast-forward/rewind here, also, for video app there is no such feature because no next/previous buttons for the playing controls.

Lecky, are you talking about the seeking on the duration slider?
Flags: needinfo?(lecky.wanglei)
(Reporter)

Updated

4 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(lecky.wanglei)
Resolution: --- → WONTFIX

Updated

4 years ago
Whiteboard: [c=effect p= s= u=] → [c=effect p= s=2013.12.20 u=]

Updated

4 years ago
Target Milestone: --- → 1.3 C1/1.4 S1(20dec)
You need to log in before you can comment on or make changes to this bug.