CSS1 background-image: does not work

VERIFIED FIXED

Status

()

Core
Layout
VERIFIED FIXED
17 years ago
4 years ago

People

(Reporter: Roland Lammel, Assigned: karnaze (gone))

Tracking

Trunk
HP
HP-UX
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

17 years ago
While running through the w3c CSS1 test-suite, I experienced a missing
backgrounds through the whole section 5.3
(http://www.w3.org/Style/CSS/Test/current/sec53.htm).

Not a single background-image was rendered. (Tested it with Netscape 4.78 it
worked... actually the background stuff was the only thing wokring ;)

As I haven't found a bug matching that problem exactly I filed this one.
It might be related (or a dup) of bug 91789 ("background-image CSS1 property not
working in form textfield")

Seeing bug 91789 it seems that background: does work, only background-image: not.

As Mozilla should be as standards-compliant as possible I guess it should render
the W3 CSS1 Tests correct.

Comment 1

17 years ago
may be a dupe of bug 91034

Comment 2

17 years ago
Roland: this bug was probably fixed yesterday by the imageLib landing (bug 
78690).  Could you please download a new nightly build and give it a try?  
Thanks.

http://ftp.mozilla.org/pub/mozilla/nightly/latest/
(Reporter)

Comment 3

17 years ago
Checked this with Mozilla for Windows (Win NT 4.0/SP5) 0.9.3 (which has
Gecko/20010807) and everthing seems to work fine.

It may be a problem with HP-UX only, but as 10.20 is not supported in the
nighlty builds, I'll have to wait for the next release I guess.

Comment 4

17 years ago
Marked qawanted.  We need to test this on HP-UX.
Keywords: qawanted

Comment 5

17 years ago
Barrett can you check this on hpux 11.00 (nightly build) and on linux to see
if it works on either of those?  Also since he tested this on win32 0.9.3
you could run the hp10.20 build (that is up on mozilla.org) on messina to 
test it in Roland's env.

jim

Comment 6

17 years ago
Ok, here's what I got:

Works on Hpux 11i and 11.00 using Builds #2001082121 commercial and mozilla.
Works on Linux using build #2001082208
Does NOT work on Hpux 10.20 using mozilla build #2001080609 (from mozilla.org).

Comment 7

17 years ago
Thanks Barrett.  The ImageLib landing (bug 78690) occured 1 or 2 days after 
#2001080609.

Marked fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 8

17 years ago
Marking verified in the Sept 06 th build (2001-09-06-05).
Status: RESOLVED → VERIFIED
Keywords: qawanted
You need to log in before you can comment on or make changes to this bug.