Closed Bug 942739 Opened 9 years ago Closed 8 years ago

labanquepostale.mobi sends invalid mobile content to FirefoxOS

Categories

(Web Compatibility :: Mobile, defect)

ARM
Gonk (Firefox OS)
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: gerard-majax, Assigned: karlcow)

References

()

Details

(Whiteboard: [country-fr][serversniff][sitewait])

Attachments

(1 file)

Attached image 2013-11-25-10-08-01.png
Site: http://labanquepostale.mobi
labanquepostale.mobi sends invalid mobile content to FirefoxOS

:: Steps To Reproduce

Goto labanquepostale.mobi with FirefoxOS and Android, and compare rendering.

:: Expected Result

Correct viewport

:: Actual Result

Invalid viewport, makes the website unusable
I already contacted them via the client support channel, the « transmitted to the correct service »
Forcing a Firefox Android user agent in B2G's prefs for this website circumvent the issue.
They're doing some server-side sniffing to either send some super old legacy site (presumably to unknown UAs), or a WAP site (to the Firefox for Android UA, and iOS, probably others). They all land on the same page [1] but with different content.

See https://gist.github.com/miketaylr/7643127

The "about:legacy-compat" page lacks meta@viewport and instead has a width of 760px on body via inline style. Removing that fixes the site. But we should contact them and recommend they send the WAP site to FxOS (the same that they do for other mobile browsers).

[1] Location: https://labanquepostale.mobi:443/finance/mobile/canalBKML/particulier/homepage/particulier-homePage.ea
Whiteboard: [country-fr][serversniff][contactready]
Assignee: nobody → kdubost
Contacté http://twitter.com/MozWebCompat/status/409036861802549248
Status: NEW → ASSIGNED
OS: Linux → Gonk (Firefox OS)
Hardware: x86_64 → ARM
The current CTO is http://www.linkedin.com/pub/jego-eric/10/804/b45
but no precise contact information.

Their twitter account is just broadcasting information. No interaction at all. So not very useful for contacts.

The contact page doesn't really propose a way to address technical issues with their infrastructure. It is made for banking customers.
https://www.labanquepostale.fr/particuliers/outils/contacts.html

Oh…
https://www.labanquepostale.fr/transversal/popups/credits.html
Conception : Angie (www.angie.fr) FullSix (www.fullsix.fr)
Réalisation : Valtech Agency
Gestion de contenus : Adobe Experience Manager
Crédits photo : Getty - Corbis - Fotolia
Julien Millet
André Tudela

Irony I worked a little bit for Angie in 1999/2000, but I don't think I have any contacts left there… 14 years…

Let's see 
http://twitter.com/MozWebCompat/status/456243388388352000
http://twitter.com/MozWebCompat/status/456249992227737600
I've got a twitter contact who works at Valtech Agency if it can be of any help. Maybe we could get some email contact going this way.
Can you help us?
Flags: needinfo?(tifftafftoff)
Thanks for the reminder, I tried to contact my contact again at and finally got a response. Valtech Agency didn't made the mobile version of the website and they weren't able to give me a contact inside the tech department of La Banque Postale. :/
Flags: needinfo?(tifftafftoff)
Thanks tifftafftoff.
I'm asking Angie again
http://twitter.com/MozWebCompat/status/483767855515578368
(In reply to Karl Dubost :karlcow from comment #9)
> Thanks tifftafftoff.
> I'm asking Angie again
> http://twitter.com/MozWebCompat/status/483767855515578368

Still no news then :(
FYI being one of their client, I've re-asked some news on this topic. Last time I did was back in november 2013 and their reply was "forwarded to the proper service". And no news since.
Trying to contact a human
http://twitter.com/MozWebCompat/status/501981511940186112
Whiteboard: [country-fr][serversniff][contactready] → [country-fr][serversniff][sitewait]
I just got off the phone with them, after a long battle the very kind personal manager found the proper contacts and transfered all the informations regarding this to the people in charge of it. So I have good hopes it will move soon, and they have my number to reach me in case of issue :).

Kudos to whoever helped me on the phone with this :)
Summary

# Chrome Mobile on Android UA
==============================
(No issue)

redirection to
https://labanquepostale.mobi/finance/mobile/canalBKML/particulier/homepage/aiguillageInterstitiel-homePage.ea?mobile=ANDROID

Markup
<!DOCTYPE html
  PUBLIC "-//WAPFORUM//DTD XHTML Mobile 1.1//EN" "http://www.openmobilealliance.org/tech/DTD/xhtml-mobile11.dtd">
<html xmlns="http://www.w3.org/1999/xhtml"><head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Banque Postale</title>
<meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
<meta name="format-detection" content="telephone=no" />
…

# Safari iOS
============
(No issue)

redirection to 
https://labanquepostale.mobi/finance/mobile/canalBKML/particulier/homepage/aiguillageInterstitiel-homePage.ea?mobile=IPHONE

Same Markup


# Firefox for Android
=====================
(No issue)

redirection to https://labanquepostale.mobi/finance/mobile/canalBKML/particulier/homepage/aiguillageInterstitiel-homePage.ea?mobile=ANDROID


# Firefox OS
============
(Bad)

redirection to https://labanquepostale.mobi/finance/mobile/canalBKML/particulier/homepage/aiguillageInterstitiel-homePage.ea

Markup
<!DOCTYPE html  SYSTEM "about:legacy-compat">
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=UTF-8" />
<title>Banque Postale</title>


Solution:
Add 
    <meta name="viewport" content="width=device-width, initial-scale=1.0"/>


btw, "user-scalable=no" is a bad idea. :)
It is an important accessibility feature and should be used only for things like games with a very fixed background/canvas.
See http://www.bbc.co.uk/guidelines/futuremedia/accessibility/mobile/design/zoom
(In reply to Alexandre LISSY :gerard-majax from comment #13)
> I just got off the phone with them, after a long battle the very kind
> personal manager found the proper contacts and transfered all the
> informations regarding this to the people in charge of it. So I have good
> hopes it will move soon, and they have my number to reach me in case of
> issue :).
> 
> Kudos to whoever helped me on the phone with this :)

One month later, no news. Either this will take a looong time, or the people I got on the phone just told me bullshit to get me out.
(In reply to Alexandre LISSY :gerard-majax from comment #16)
> One month later, no news. Either this will take a looong time, or the people
> I got on the phone just told me bullshit to get me out.

Sometimes it takes long time. We had an ebay bug which took more than 6 months, because they were remodeling their architecture and didn't want to fix this before that.
Sometimes people have bosses too, who have a different opinions of the resolutions. 

^_^ Courage.
(In reply to Karl Dubost :karlcow from comment #17)
> (In reply to Alexandre LISSY :gerard-majax from comment #16)
> > One month later, no news. Either this will take a looong time, or the people
> > I got on the phone just told me bullshit to get me out.
> 
> Sometimes it takes long time. We had an ebay bug which took more than 6
> months, because they were remodeling their architecture and didn't want to
> fix this before that.
> Sometimes people have bosses too, who have a different opinions of the
> resolutions. 
> 
> ^_^ Courage.

Of course, but I have been told that someone will contact me soon.
And this seems to be fixed. \o/
Thanks Alexandre for all your efforts
and to La Banque Postale team. 

Happy Web.
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Web Compatibility
You need to log in before you can comment on or make changes to this bug.