releng fake root certificate missing from xp ix test machines

RESOLVED FIXED

Status

Infrastructure & Operations
RelOps
RESOLVED FIXED
5 years ago
4 years ago

People

(Reporter: bhearsum, Assigned: Q)

Tracking

Details

Attachments

(1 attachment)

103.66 KB, image/jpeg
Details
(Reporter)

Description

5 years ago
We noticed this while investigating test failures in bug 930194 - this certificate should in the "Trusted Root Certificate Authorities" for the SYSTEM account. Windows 7 and Windows 8 are set-up correctly, but I checked a few XP machines and none of them seemed to have the certificate installed.
Assignee: relops → mcornmesser
Has this been fixed?
Flags: needinfo?(mcornmesser)
Assignee: mcornmesser → q
Flags: needinfo?(mcornmesser)
We have debating on the best way to make this work. Q said that he has GPO template that will be able to get this done, and that he will push it out tonight.
(Assignee)

Comment 3

4 years ago
Created attachment 8355390 [details]
fakecert.jpg

Fake moz cert ca installing on xp
(Assignee)

Comment 4

4 years ago
GPO Install_mozilla_root_certs now active for XP machines ( see attachment for results of gpupdate). Changes will go out as machines reboot. Can we verify this provides the expected behavior ?
Status: NEW → ASSIGNED
Flags: needinfo?(bhearsum)
After the machines have rebooted I will submit a patch to try to verify that this is working as expected. After that I'll get it reviewed and land it on mozilla-central as well so this will be checked on every Windows xpcshell test run. How will I know that the machines have rebooted so I can start on the above?
no good way to confirm from your end at the moment (sadly) -- but submitting to try by early tomorrow AM should be plenty of time to ensure that all machines that are active reboot first.
I have seen a Win XP machine running the tests that require the certificate so it appears to be working. Just need to wait on all of the Win XP machines having the fix. Thanks!
(Reporter)

Comment 8

4 years ago
Thanks all!
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Flags: needinfo?(bhearsum)
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.