[Gaia] Sometimes the blue highlights shown on a touch does not appear anymore

RESOLVED WORKSFORME

Status

()

Core
Panning and Zooming
RESOLVED WORKSFORME
5 years ago
5 years ago

People

(Reporter: vingtetun, Unassigned)

Tracking

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

I didn't found some reliable steps to reproduce this issue at the moment but it has happens to me a few times already.

With APZ turned on sometimes the blue highlight stops working after a while. I have seen that mostly into the Dialer app for the moment but I *think* I have seen it into other apps as well.

The highlight seems to be the only thing that stops working, touch events still work. The only way to get back the highlight is to kill the app and relaunch it.
I think it could have be a duplicate of bug 942701.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 942701
I'm still seeing it sometimes. So probably not a dup in fact since this is with the APZ code path.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
When it happens on the Dialer app, it seems like I need to restart Gecko to get it working again. Then if I kill the app and start it again then it reproduce. Is there any global information with keep?
(In reply to Vivien Nicolas (:vingtetun) (:21) (RTO - Review Time Off until 09/12/13) from comment #3)
> When it happens on the Dialer app, it seems like I need to restart Gecko to
> get it working again. Then if I kill the app and start it again then it
> reproduce. Is there any global information with keep?

I can reproduce that on Settings as well. Is there only one APZCTreeManager ? If yes, then it could be that something in it is wrong.
Yes, there is only one APZCTreeManager.
The good thing is that now it is consistent and I never see it on my device for the dialer app, even when rebooting :)
I don't see it any more with today's build and patches from bug 943846, bug 940706, bug 814435. The one related to events may be related to that, but the previous version was not fixing that.

Anyway, let's close again this bug and hope there is not other way to reproduce it.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.