[sk] Merge mozilla-aurora/sk to l10n-central/sk

RESOLVED DUPLICATE of bug 1256409

Status

RESOLVED DUPLICATE of bug 1256409
5 years ago
2 years ago

People

(Reporter: flod, Assigned: rozbora)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
As part of bug 939834 I've just landed some productization changes to mozilla-aurora and wanted to merge Aurora down to Central.

I tried to merge but there are several conflicts. In the meantime I transplanted the two changesets.

It would be useful to solve the conflicts and perform a clean merge once and for all.

This is the changeset (on a temporary repository) that results by running 
> hg merge --tool internal:local
which means: merge, in case of conflicts keep what's on l10n-central and discard mozilla-aurora

https://bitbucket.org/flod/temp_sk/commits/bb97c36a1856fd92df5f08354bc306015cbe929b
From what I can see there are two, the first one is a plaintext readme.txt, that's by design and the other one is the styleinspector.properties which is due to bug 939122. Unless I'm reading it wrong it seems like wontfix to me?
(Reporter)

Comment 2

5 years ago
For sure it's not a wontfix ;-)

The idea is that we need to merge Aurora down to Central, and from that point start using merges properly. 

If you need a change on both Aurora and l10n-central:
a) Do your changes and commit to mozilla-aurora
b) Import in l10n-central the new changes
> hg pull -r default ../mozilla-aurora
> hg merge

Check if everything looks good and commit this merge
> hg commit -m "Merge Aurora to Central"

Need to change something on Beta? Fix it, merge down to Aurora and then again to Central.

On merge day follow this document to port you changes from l10n-central to mozilla-aurora
https://developer.mozilla.org/en-US/docs/Mozilla/Localization/Uplifting?redirectlocale=en-US&redirectslug=Uplifting_a_Localization_from_central_to_aurora

But to do this we need an actual merge.
No no no, that won't work. Anything to be changed on beta or aurora needs to be tested on central first and only then backported to aurora/beta. Definetely not vice-versa. Is there a "proper" way to do so that would suit you?
(Reporter)

Comment 4

5 years ago
(In reply to Vlado Valastiak [:wladow] @ Mozilla.sk from comment #3)
> No no no, that won't work. Anything to be changed on beta or aurora needs to
> be tested on central first and only then backported to aurora/beta.
> Definetely not vice-versa.

You can always do the change on l10n-central, test it, and then proceed with landing on Aurora/Beta and merging down. You shouldn't have any conflicts in that case, because files will be the same.
(Reporter)

Comment 5

3 years ago
Vlado, should we close this as WONTFIX?
(Reporter)

Comment 7

2 years ago
Yes, it was done in bug 1256409. Thanks Michal.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1256409
You need to log in before you can comment on or make changes to this bug.