Sheets are white during the opening animation

VERIFIED FIXED in Firefox 27

Status

()

defect
VERIFIED FIXED
6 years ago
6 years ago

People

(Reporter: mstange, Assigned: mstange)

Tracking

({regression})

Trunk
mozilla28
All
macOS
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27 verified, firefox28 verified)

Details

Attachments

(1 attachment)

Posted patch whitesheetsSplinter Review
This is a regression from https://hg.mozilla.org/mozilla-central/rev/03f9c4191bf0 (bug 914437).

Sheets are white during their opening animation because we refuse to composite them during their initial drawRect because they return NO from isVisibleOrBeingShown because nothing sets their mBeingShown flag to YES during window opening. For normal windows, this happens through the overrides for the NSWindow methods orderFront and makeKeyAndOrderFront, but those aren't called for sheet opening.
I've moved the flag setting out of the overrides and into nsCocoaWindow::Show.
Attachment #8337824 - Flags: review?(smichaud)
Comment on attachment 8337824 [details] [diff] [review]
whitesheets

Looks good to me.
Attachment #8337824 - Flags: review?(smichaud) → review+
It's conceivable this will fix bug 924456.
https://hg.mozilla.org/mozilla-central/rev/0b33a1945d79
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla28
Comment on attachment 8337824 [details] [diff] [review]
whitesheets

It seems I forgot to get this regression fix uplifted during the Aurora time frame. Sorry :(

[Approval Request Comment]
Bug caused by (feature/regressing bug #): bug 914437
User impact if declined: "sheet"-style dialog boxes don't get painted during their slide-down opening animation (about half a second long), they're white during that time
Testing completed (on m-c, etc.): three weeks on mozilla-central
Risk to taking this patch (and alternatives if risky): very low
String or IDL/UUID changes made by this patch: none
Attachment #8337824 - Flags: approval-mozilla-beta?
Attachment #8337824 - Flags: approval-mozilla-beta? → approval-mozilla-beta+
Tested using the xpi in bug 924456. The slide-down dialog is white for an extremely short time on Firefox 27 beta 1, which doesn't happen anymore on beta 4 and the 01/08 Aurora. Considering that this bug is displayed for less than a second, I can't be 100% sure of what I'm seeing though.

Is there anything else that could be tested more reliably for this fix?
Flags: needinfo?(mstange)
What you describe sounds exactly like what this bug was fixing, so I'd say your testing was enough to verify that it works. If you wanted to, you could make a screen recording and step through the video frame-by-frame, but I don't think that's worth the time.
Flags: needinfo?(mstange)
Thanks Markus! Marking the bug as verified per previous comments.
Status: RESOLVED → VERIFIED
Keywords: verifyme
You need to log in before you can comment on or make changes to this bug.