Sorting a bookmark folder no longer sorts purely alphabetically

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: dubovspe.duckcreektech.com, Unassigned)

Tracking

25 Branch
x86_64
Windows 7
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:25.0) Gecko/20100101 Firefox/25.0 (Beta/Release)
Build ID: 20131112160018

Steps to reproduce:

I have a folder on my bookmarks toolbar that contains both bookmarks and other folders. I right-clicked this folder and chose Sort By Name.


Actual results:

The folders within this folder all floated to the top instead of being sorted alphabetically like they used to do. 


Expected results:

Folders should be intermixed with bookmarks alphabetically instead of being listed first. This is the way Sort By Name worked in previous versions, so there should at least be an option in about:config to go back the old behavior.
Hi Pete, alphabetical sort is actually working first according to the types of items you have in your main/root bookmarks folder. If you have additional folders inside it, they will be sorted separately and positioned at the top of the list, followed by the sorted bookmarks. This behavior is by design, not erroneous.

If you're looking for a more advanced way of sorting your bookmarks, you could try using the "Auto-Sort Bookmarks" add-on: https://addons.mozilla.org/en-US/firefox/addon/auto-sort-bookmarks/.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Component: Untriaged → Bookmarks & History
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.