Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 925480
5 years ago
4 years ago

People

(Reporter: Praveen A, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

5 years ago
User Agent: Mozilla/5.0 (Mobile; rv:28.0) Gecko/28.0 Firefox/28.0 (Nightly/Aurora)
Build ID: 20131120013316

Steps to reproduce:

Configure an email account.
Open email app


Actual results:

New mails are listed but when opening any mail it keeps rotating forever. I was able to read it once in so many tries. It was broken on 1.0 and on 1.3 build of 19 Nov.


Expected results:

Email should be readable reliably.
(Reporter)

Comment 1

5 years ago
So as a workaroud, I check mail on browser.
Severity: normal → blocker
Hi Praveen,

We'll need more information to act on this; please take a look at the following links for instructions on how to provide e-mail specific debugging information that we can use to help identify your issue:

https://wiki.mozilla.org/Gaia/Email/ProvidingEmailsForDebugging
https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo

Since this issue sounds like it could be either e-mail-specific or account-specific, we'll probably need the logs/info from both of those links above.

Thanks!
Flags: needinfo?(pravi.a)
(Reporter)

Comment 3

5 years ago
Created attachment 8338745 [details]
email-log.txt
Flags: needinfo?(pravi.a)
(Reporter)

Comment 4

5 years ago
Type of device: ZTE Open (bought from ebay.in)

Net connection is working as message list is updated.

Email domain - gmail.com

Account type: IMAP+SMTP

logcat log is attached
(Reporter)

Comment 5

5 years ago
Because of lack of option to override certificates (https://bugzilla.mozilla.org/show_bug.cgi?id=919807), I cannot try other accounts right now.
(Reporter)

Comment 6

5 years ago
after installing a CA root certificate, I was able to try another account and it seems to be working. Email domain - autistici.org
Okay, I'm going to close this bug then. Feel free to reopen if you are able to reproduce the issue.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME
Ah wait, my mistake, I didn't see comment #3. I'm investigating that now.
Status: RESOLVED → REOPENED
Ever confirmed: true
Resolution: WORKSFORME → ---
Severity: blocker → normal
(Reporter)

Comment 9

5 years ago
I think mozilla still considers Firefox OS phone a toy phone for hackers if it thinks it is okay to ship a smart phone with a broken email app. I guess we will need to buy an android, jolla or ios phone if we really want smart phone functionality.

Btw, autistici.org account also stopped working completely, I don't get any new emails. Both accounts works well with thunderbird, so it can't be a problem with my account.
(In reply to Praveen A from comment #9)
> Btw, autistici.org account also stopped working completely, I don't get any
> new emails. Both accounts works well with thunderbird, so it can't be a
> problem with my account.

It's probably a bug in the e-mail app :(.  A quick, if undesirable and a total hassle, thing you can try is to remove the account and re-add it.  This will frequently fix breakages that are a result of user action triggering an e-mail app bug or manage to avoid reproducing e-mail bugs triggered by synchronizing certain messages because whatever e-mail message broke the app will no longer be synchronized.  In the latter case, if you scroll back and keep doing "load more messages" you may eventually re-encounter whatever message broke the sync, in which case you will be unable to sync beyond that point and may need to restart the app.

The most useful thing you can do to help us diagnose problems is provide a logcat; please see https://wiki.mozilla.org/Gaia/Email/RequiredBugInfo for some helpful info on how to provide a logcat.  Please also be sure to provide at the very minimum the version of gaia you are using, there are unfortunately many bugs in the v1.0.1 and v1.1 releases that have been fixed in v1.2 and the pending v1.3 release.
(Note that I see you said you were using the ZTE open previously.  While it ships with v1.0.1, v1.1 is available per https://developer.mozilla.org/en-US/Firefox_OS/Developer_phone_guide/ZTE_OPEN although current reports are that using the SD card upgrade package *will wipe out your user data*.  I think efforts are under-way to get a release that does not wipe out user data, but you might just have to wait for the v1.0.1 device to see a v1.1 update on the web.)
(In reply to Praveen A from comment #3)
> Created attachment 8338745 [details]
> email-log.txt

The error signature from this log is:
11-27 01:52:34.926 I/Gecko   ( 1325): WERR: Explosion while processing data TypeError: box.attribs is undefined
11-27 01:52:34.926 I/Gecko   ( 1325): WERR: Stack: ImapAccount.prototype._determineFolderType@app://email.gaiamobile.org/js/ext/mailapi/composite/configurator.js:3539

This looks like bug 835149 which was fixed on all released versions (well, v1.0.1 and later).

This suggests the specific bug in question is something similar but different, but that fix was pretty thorough.  We'd want a protocol trace covering the:
  LIST "" "*"

The easiest way to get this info is, on linux to do (don't type the spaces, indenting for delineation):
  openssl s_client -connect <IMAPHOST>:993
(wait for the connection)
  A1 LOGIN <username> <password>
(wait for it to auth you)
  A2 LIST "" "*"
(copy and paste what it reports and paste it in the bug here or privately mail it to asuth@mozilla.com and mcav@mozilla.com unless you don't care about people knowing your folder names.  You can also try and only provide the things that look suspicious if you know what to look for.  You can also redact folder names by transforming them.  In general as long as unique strings are mapped to other unique strings consistently, we are fine.  Don't need to know the actual strings.  Note that it would also be handy to have the CAPABILITY string the server reports and any login greeting.  Just absolutely do not copy and paste your username/password.)
(Reporter)

Comment 13

4 years ago
I tried these commands but imap.gmail.com doesn't recognize these commands (A1 BAD Too many arguments provided). I could login to mail.dreamhost.com using these commands (this account is working fine so far).

I have unicode labels/folders if that info is helpful. इनबॉक्स (INBOX), [കേരളം] etc.
(Reporter)

Comment 14

4 years ago
when run
openssl s_client -connect imap.gmail.com:993 -crlf

it responds but it keeps on asking for web login

* NO [WEBALERT ***] Web login required.
a001 NO [ALERT] Please log in via your web browser: http://support.google.com/mail/accounts/bin/answer.py?answer=78754 (Failure)

but it started working after using manual connection for gmail.
Thank you for trying to get the log again!  On bug 925480 I think we have the identical problem and pancake provided logs that have allowed me to identify the source of the problem.  I think we can target the fix for v2.0.
Status: REOPENED → RESOLVED
Last Resolved: 5 years ago4 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 925480
You need to log in before you can comment on or make changes to this bug.