TouchPal Korean input does not create syllable blocks in awesomebar and pinned top sites edit screen

RESOLVED INVALID

Status

()

Firefox for Android
Keyboards and IME
RESOLVED INVALID
4 years ago
4 years ago

People

(Reporter: mcomella, Unassigned)

Tracking

unspecified
All
Android
Points:
---

Firefox Tracking Flags

(firefox32 affected)

Details

1) Install TouchPal, enable it, and enable Korean input (settings -> languages -> more languages -> Korean)
2) Click the url bar
3) Use the TouchPal IME and change to the Korean layout (click the little keyboard with "EN" on it, select Korean)
4) Type "ㅇ", followed by "ㅏ"

Expected: "아" is input into the awesomebar
Actual: "ㅇㅏ" is input into the awesomebar

Typing certain combinations of two successive characters (specifically a consonant followed by a vowel) should create a syllable block, i.e. ㅇ + ㅏ = 아, not ㅇㅏ.

All valid Korean words use these syllable blocks and without this functionality, the layout is useless.

I can reproduce this on the awesomebar, and the pinned top sites edit screen.

I could not reproduce in web content, nor the edit bookmark dialog.

Google's Korean IME does not have this issue.
While I assume getting two character blocks to work would make more numerous blocks work, it may be worthwhile to test 3 and 4 character blocks (that is the maximum). Try:

3: ㅇ + ㅏ + ㄴ = 안

4: ㅇ + ㅏ + ㄴ + ㅎ = 않
status-firefox32: --- → affected
Pretty sure it's a TouchPal bug. I can make the bookmark edit not work by adding a URI input type. Chrome also has the same problem. I didn't look too closely, but seems like the best way to report a TouchPal bug is through Twitter.
(In reply to Jim Chen [:jchen :nchen] from comment #2)
> Pretty sure it's a TouchPal bug. I can make the bookmark edit not work by
> adding a URI input type. Chrome also has the same problem.

So it seems. I'm sending them an email.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.