[DSDS] Dialer doesn't come up when a call is placed or received on SIM2

RESOLVED INVALID

Status

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: anshulj, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(6 attachments)

(Reporter)

Description

5 years ago
STR.

1. Make an incoming call for SIM2

Observed: Call is received by RIL but the dialer doesn't show up.
Expected: Dialer to show the incoming call UI.
Anshul, we fixed this issue in bug 940231. Not sure if your gecko is up-to-date?
(Reporter)

Comment 2

5 years ago
Hsin-Yi, yes just confirmed that my build has this change already.

Gecko SHA: e5147f9a670e3a315a8aedbf11c3b9672affe8a2 
Gaia SHA: e48c2025b97f26db6e23c16d72095143d731b1fa
Created attachment 8338518 [details] [diff] [review]
0001-gaia-debug-messages.patch
Created attachment 8338519 [details] [diff] [review]
0001-gecko-debug-message.patch
Anshul, in addition to enabling RIL debugger as usual, please apply attachment 8338518 [details] [diff] [review] and attachment 8338518 [details] [diff] [review] to get more debug messages. Hope they help!
(Reporter)

Comment 6

5 years ago
Created attachment 8338734 [details]
Logs with gecko and gaia debug patches by Hsin-Yi
(Reporter)

Comment 7

5 years ago
Hsin-Yi, from the logs it seems like telephony is doing the right thing. I do see a flicker on the UI as if the dialer was starting and then goes away.
(In reply to Anshul from comment #7)
> Hsin-Yi, from the logs it seems like telephony is doing the right thing. I
> do see a flicker on the UI as if the dialer was starting and then goes away.

Thanks for the feedback. :)

Yes, I also noticed that log shows dialer has successfully received the event fired on telephony, and call screen is opened as expected. 

You mentioned that then UI goes away. Does that mean you still see a problem with dialer UI, i.e. UI disappeared unexpectedly when there's still a call?
(Reporter)

Comment 9

5 years ago
Hsin-Yi, yes the dialer disappears right away (very quickly). I just see sort of a flicker on the UI.
ni gaia developers to see if they see some clues.
Flags: needinfo?(rexboy)

Comment 11

5 years ago
Test with today's build, 2nd SIM incoming call UI is normal and can hang up calls.
Fugu
Gaia:     087d109c83235fc157b2efac7ace6cc54a4c5aaa
Gecko:    8fdb69114734785065ce6c76ac36f4438b90c2e6
BuildID   20131127093419
Version   28.0a1

repository from https://github.com/prcxuying/B2G.git

Comment 12

5 years ago
Created attachment 8339022 [details]
time stamp: 11:34, passed log.
(Reporter)

Comment 13

5 years ago
Enpei, we are consistently seeing this issue reported by multiple people on our hardware. Is there some logs you could enable and share the patch with me to help debug the issue? This is a critical bug for us.

Comment 14

5 years ago
Hi (In reply to Anshul from comment #13)
> Enpei, we are consistently seeing this issue reported by multiple people on
> our hardware. Is there some logs you could enable and share the patch with
> me to help debug the issue? This is a critical bug for us.

Hi Anshul,

I attached a log in comment 12. Do you need more logs with other configuration enabled? Please just let me know. Also I can only test MT to 2nd SIM now since I cannot change outgoing call to SIM 2 at this point, there is no SIM manager ready yet. So let me know any other information I can provide.
(Reporter)

Comment 15

5 years ago
Enpei, the log you attached has no messages from dialer (execept a few warnings). I am looking for a patch that you can share with me that would help you debug the issue with dialer on our hardware. Also, you can test MO call on SIM2 using the patch available in bug 932731 (I have verified that the patch works).
(In reply to Anshul from comment #15)
> Enpei, the log you attached has no messages from dialer (execept a few
> warnings). I am looking for a patch that you can share with me that would
> help you debug the issue with dialer on our hardware. 

Anshul, our gaia developer is working on this. We will provide you another debug message patch if we find some important clues are missing in my gaia debug patch. 

> Also, you can test MO
> call on SIM2 using the patch available in bug 932731 (I have verified that
> the patch works).

Comment 17

5 years ago
Created attachment 8339066 [details]
Log with gaia and gecko patches, time stamp 13:57 MO from 2nd SIM, 13:58 MT to 2nd SIM.

Add sucessful case log on current build 

Gaia:     7c1198f3bfc24be17f78b94e13f2a69ddce17375
Gecko:    a787b2210bb136607581e7f566f648654e9baec7
BuildID   20131127133749
Version   28.0a1
(Reporter)

Comment 18

5 years ago
Enpei, please also look at the attachment "Logs with gecko and gaia debug patches by Hsin-Yi" in which I also see 'XXX openCallScreen' but dialer doesn't start.
Created attachment 8339108 [details]
patch for testing

Please apply this patch and get the log again.
Not very sure where the problem is, I added logs mainly around showing call screen and attention screen.
Thanks!
Flags: needinfo?(rexboy)

Comment 20

5 years ago
Rex, can you own this bug? Thanks.
Flags: needinfo?(rexboy)
(Reporter)

Comment 21

5 years ago
@rexboy, thanks for your patch using which I was able to find the issue in our code causing this issue. This issue is now resolved.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
blocking-b2g: 1.3? → ---
clearing ni per comment 21.
Flags: needinfo?(rexboy)
You need to log in before you can comment on or make changes to this bug.