Closed Bug 943210 Opened 6 years ago Closed 6 years ago

[DSDS] RSSI is not correct when there is only one SIM inserted.

Categories

(Firefox OS Graveyard :: Gaia::System, defect)

x86_64
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:1.3+, firefox29 fixed, b2g-v1.3 fixed)

VERIFIED FIXED
1.3 Sprint 6 - 12/6
blocking-b2g 1.3+
Tracking Status
firefox29 --- fixed
b2g-v1.3 --- fixed

People

(Reporter: echu, Assigned: arthurcc)

References

Details

(Whiteboard: [dsds_US_test])

Attachments

(3 files)

Attached file Slot 0 with SIM
RSSI is not displayed correctly when there is only one SIM inserted into DUT.

* Build Number                
Gaia:     671a7c1fae1c32a77b2675636c7efdf089fd6443
Gecko:    b79ea773754854e17566f302e80e2654d9c155c9
BuildID   20131126092608
Version   28.0a1

* Reproduce Steps
1. Insert SIM into slot 0.
RSSI: 2 SIM icons are the one for out of range.
2. Insert SIM into slot 1 while 0 has no card.
RSSI: SIM 1 has no signal and grey icon, SIM 2 has signal bars.

* Expected Result
Slot with SIM should have signal bars, and the one with no SIM should have a SIM icon next with "!".

* Occurrence rate
100%
blocking-b2g: --- → 1.3?
Whiteboard: [FT:RIL]
Attached file Slot 1 with SIM
Whiteboard: [FT:RIL] → [dsds_US_test]
Summary: [fugu] RSSI is not correct when there is only one SIM inserted. → [fugu][DSDS] RSSI is not correct when there is only one SIM inserted.
Arthur, can you please handle this bug.
blocking-b2g: 1.3? → 1.3+
Flags: needinfo?(arthur.chen)
Summary: [fugu][DSDS] RSSI is not correct when there is only one SIM inserted. → [DSDS] RSSI is not correct when there is only one SIM inserted.
Blocks: 938440
Assignee: nobody → arthur.chen
Flags: needinfo?(arthur.chen)
This is a bug, not a feature work.
Target Milestone: --- → 1.3 Sprint 6 - 12/6
Duplicate of this bug: 948708
No longer blocks: 938440
See Also: → 938440
Component: Gaia → Gaia::System
The patch removes IccHelper and use SIMSlotManager instead. Alive, could you help review the patch? Thanks!
Attachment #8357689 - Flags: review?(alive)
Thanks for reviewing.

master: 509c7a63a8431e28850ae2e43ceb73399093b5b9
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Uplifted 509c7a63a8431e28850ae2e43ceb73399093b5b9 to:
v1.3: 2cf44785fbfc12ff4fbd4c02d4ef8547b39f52cc
Verified on Fugu, passed.

Gaia      a119a0692c24c5ed7c55bab838bae3ecdb9dbec9
Gecko     15ee4e78431b45922b41dea882464b0ccb6b4fac
BuildID   20140110174141
Version   28.0a2
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.