Closed Bug 943220 (sw-devtools) Opened 7 years ago Closed 2 years ago

[meta] DevTools should support ServiceWorkers

Categories

(DevTools :: General, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1262699

People

(Reporter: nsm, Unassigned)

References

(Depends on 2 open bugs, Blocks 1 open bug)

Details

(Keywords: meta)

Just filing a bug since it was on the top of my head:

We'd want devtools to understand when resources were being generated by a ServiceWorker and show relevant UI hints to web developers. In addition, the ability to discover the ServiceWorker(s) active on a given page and debugging through the ServiceWorker script should be supported.
I guess this bug can only be worked on once the spec+implementation is in reasonable shape.
Depends on: ServiceWorkers
Depends on: 1092102
Alias: sw-devtools
Depends on: 1209369
Depends on: 1209640
Depends on: 1175550
Blocks: 1188675
Summary: DevTools should support ServiceWorkers → [meta] DevTools should support ServiceWorkers
Depends on: about:debugging
Depends on: 1214248
Note: Trying to show the dependency graph fails with "The dependency graph contains too many bugs to display (more than 2000 bugs)."
Depends on: 1169553
Depends on: 1158264
Depends on: 1003860
Depends on: 1216309
Depends on: 1212344
No longer depends on: 1221772
Product: Firefox → DevTools

There are two meta bugs which aim to track the same; this one and Bug 1262699. The distinction is not clear and we're never sure which one to block. So I moved the dependencies of this one to the bug with more dependencies, and I'm going to close this one as "duplicate".

No longer blocks: dt-service-worker
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: dt-service-worker
You need to log in before you can comment on or make changes to this bug.