[music] An error image overlaps the default album art in album content view

RESOLVED FIXED

Status

Firefox OS
Gaia::Music
RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: dkuo, Assigned: dkuo)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Assignee)

Description

4 years ago
Created attachment 8338353 [details]
2013-11-11-10-57-07.png

Reproduce steps:
1. Launch music app and select artists/albums view.
2. Select one artist/album with embedded cover image and enter the album content view.
3. Back to artists/albums view then select another artist/album with default album art.
4. Entered the album content view but an error image overlaps the default album art.
(Assignee)

Updated

4 years ago
blocking-b2g: --- → koi?

Updated

4 years ago
Keywords: regressionwindow-wanted

Updated

4 years ago
QA Contact: sarsenyev

Comment 1

4 years ago
Unable reproduce this issue on the 1.2 or 1.3 build
I tried different files with an embedded cover image, even tried a file with a corrupted ID3 Tag, but the 
error image doesn't appear along with embedded cover image in the album view, if the file doesn't have an ID3 Tag.

Device: Buri 1.2 COM RIL
BuildID: 20131126004001
Gaia: 264c6044b941437ac3c4b28fe4ca392d2bc78445
Gecko: 21e2ad082d85
Version: 26.0
Firmware Version: US_20131015
RIL Version: 01.02.00.019.082

Device: Buri 1.3 Central
BuildID: 20131126052050
Gaia: 4ad796b196d468bdb231beba4392acbc90a74e96
Gecko: 99479edbee2a
Version: 28.0a1

Updated

4 years ago
Keywords: regressionwindow-wanted
(Assignee)

Comment 2

4 years ago
(In reply to sarsenyev from comment #1)
> Unable reproduce this issue on the 1.2 or 1.3 build
> I tried different files with an embedded cover image, even tried a file with
> a corrupted ID3 Tag, but the 
> error image doesn't appear along with embedded cover image in the album
> view, if the file doesn't have an ID3 Tag.

Thanks, I also cannot reproduce on 1.2, but I can reproduce on 1.3(assuming this is master)
Renominate from koi? to 1.3? because it only happened on 1.2.

Here is the build information
=================
Flash Information
=================
Your Target Build: PVT.master.inari
URL:  https://pvtbuilds.mozilla.org/pvt/mozilla.org/b2gotoro/nightly/mozilla-central-inari/latest/
ENG Ver: false
Flash: Full Image.
Gaia:     4ad796b196d468bdb231beba4392acbc90a74e96
Gecko:    http://hg.mozilla.org/mozilla-central/rev/99479edbee2a
BuildID   20131126052050
Version   28.0a1
blocking-b2g: koi? → 1.3?
(Assignee)

Comment 3

4 years ago
Created attachment 8339732 [details]
Video of this bug

Video of this bug

Updated

4 years ago
blocking-b2g: 1.3? → ---
(Assignee)

Comment 4

4 years ago
Fixed by bug 943797.
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Depends on: 943797
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.