Closed Bug 943273 Opened 6 years ago Closed 6 years ago

nsDefaultURIFixup should not rely on nsIPlatformCharset

Categories

(Core :: DOM: Navigation, defect)

defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 393246

People

(Reporter: hsivonen, Unassigned)

References

Details

We should base our guessing on something other than nsIPlatformCharset or potentially guess less in order to be able to get rid of nsIPlatformCharset. The guess is always UTF-8 on Mac, so the current guessing code isn't that great.
The only purpose of using nsIPlatformCharset is determining the charset for the URL bar.
Depends on: 393246
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 393246
You need to log in before you can comment on or make changes to this bug.