bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Camera icon/popup for gUM access can get hidden

RESOLVED FIXED in Firefox 29

Status

()

Firefox
SocialAPI
RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: standard8, Assigned: florian)

Tracking

Trunk
Firefox 29
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

STR:

1. Install Talkilla & Log in
2. Open the conversation window with someone
3. Start a call with that person
4. As the call starts, click to another application - before the permissions dialog is presented.

Actual Results

No popup appears, no camera icon in the toolbar of the conversation window

Expected Results

Grey camera icon is shown in the toolbar


Reproduced on Nightly 28.0a1 2013-11-25, but I've been seeing this for a while.
Additional comment: when I click the area where the icon should be, the icon appears and the popup is displayed.
(Assignee)

Comment 2

5 years ago
Looks like an edge case of bug 809085.
Blocks: 809085
(Assignee)

Comment 3

5 years ago
Created attachment 8338533 [details] [diff] [review]
Patch v1

This patch fixes the bug reported by Mark for the SocialAPI chat windows. I'm not sure if this bug applies to the social sidebars too (how are we displaying permission icons for the sidebar? Is it in the toolbar button that we are in the process of removing?), nor of how notification icons are displayed for social status panels.
Only the chat window case seems to matter for Talkilla, but when looking at the patch, you may want to check that it doesn't break anything for other cases; if they worked now.

Requesting feedback from Shane who wrote in bug 809085 the code I'm modifying. Will request review from Felipe later if Shane says the patch looks reasonable.
Attachment #8338533 - Flags: feedback?(mixedpuppy)
Attachment #8338533 - Flags: feedback?(mixedpuppy) → feedback+
(Assignee)

Updated

5 years ago
Attachment #8338533 - Flags: review?(felipc)
Attachment #8338533 - Flags: review?(felipc) → review+
(Assignee)

Comment 4

5 years ago
The patch was a bit old, so I pushed it to try to be sure it didn't get broken: https://tbpl.mozilla.org/?tree=Try&rev=84bf8628d59f

The results were green enough, so:
https://hg.mozilla.org/integration/fx-team/rev/00b675eb6551
Assignee: nobody → florian
OS: Mac OS X → All
https://hg.mozilla.org/mozilla-central/rev/00b675eb6551
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 29
You need to log in before you can comment on or make changes to this bug.