U+0085 and U+0092 are rendered as hexboxes

RESOLVED INVALID

Status

()

RESOLVED INVALID
5 years ago
5 years ago

People

(Reporter: Fanolian+bugzilla, Unassigned)

Tracking

Trunk
x86_64
Windows 8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

5 years ago
Created attachment 8338449 [details]
hexbox1.PNG

User Agent: Mozilla/5.0 (Windows NT 6.3; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0 (Beta/Release)
Build ID: 20131125030201

Steps to reproduce:

Visit http://www.brunomars.com/photo/first-full-day-hong-kong-other-fact-we-re-here-it-s-lot-any-other-day. Observe the page title, text on tab bar and its tooltip. (see attachment)


Actual results:

U+0085 and U+0092 are rendered as hexboxes.

This should be the same issue as bug 941940 which is regressed by bug 909344.

Regression range:
Last good nightly: 2013-11-12
First bad nightly: 2013-11-13
Pushlog:
http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=581d180a37f3&tochan
ge=7b014f0f3b03

P.S. According to bug 757521, U+0007 and U+0001 should be affected as well.
That's Web page's fault. Probably U+0085 meant to ellipsis and U+0092 meant to apostrophe.
The page author must have converted a windows-1252 text to UTF-8 using a ISO-8859-1 converter.
In windows-1252, 0x85 and 0x92 mean U+2026 and U+2019, respectively. In ISO-8859-1, they means U+0085 and U+0092. The latter is unlikely to be authors intention.
Note that even with Chrome and IE, apostrophe are missing ("were" should be "we're", "its" should be "it's"). Nightly just made the page bug more clear.
And this is the reason bug 890478 was invalid. Even if authors think they are writing ISO-8859-1 text, they actually write windows-1252 text.
Created attachment 8338479 [details]
screenshot of the site in IE 8 on WinXP

As shown here, in IE8 on WinXP the site displays .notdef box glyphs for the (intended) apostrophe (in both the window title and the content); the ellipsis is rendered as blank space.

(YMMV, depending on installed fonts.)

This is an error on the site, not a Gecko bug; it's just easier to notice it now. I'd recommend reporting the problem to the author/webmaster involved.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.