[Costcontrol] Data usage counter isn't resets after the end of a Weekly billing period.

RESOLVED WORKSFORME

Status

Firefox OS
Gaia::Cost Control
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: lolimartinezcr, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: burirun4, burirun1.3-1, burirun1.4-1)

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
1. Open the Cost Control app.
2. Press the gear button in the top right corner to open the Settings screen.
3. Set the "Reset tracking" option to Weekly.
4. Set the start of the billing period to 6 days before today.
5. Surf the internet
6. Simulate future date by changing date and time on the device
(Reporter)

Comment 1

4 years ago
testrun4 build:
Comercial RIL
Gecko-35d902d
Gaia-c736d91
OS: Windows 7 → Gonk (Firefox OS)
Hardware: x86 → ARM
Whiteboard: burirun4

Comment 2

4 years ago
Created attachment 8338481 [details]
costcontrol.txt

adb logcat when a weekly reset should be done. The data is not reseted after the weekly period finishes.
Not sure if the logs are helpful, will try to get a more complete ones.
(Reporter)

Updated

4 years ago
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

4 years ago
In burirun1.3-1 resolved
(Reporter)

Updated

4 years ago
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

4 years ago
Tested again in burirun1.3-1  and i have reproduced it.

12/16
hamachi
gecko 12e9915
gaia 888f9df
(Reporter)

Updated

4 years ago
Summary: [Costcontro] Data usage counter isn't resets after the end of a Weekly billing period. → [Costcontrol] Data usage counter isn't resets after the end of a Weekly billing period.
(Reporter)

Updated

4 years ago
Whiteboard: burirun4 → burirun4, burirun1.3-1
QA Wanted - Does this reproduce on 1.2?
Keywords: qawanted
This issue does not occur in the latest version of 1.2
Environmental Variables:
Device: Buri v1.2 Moz
BuildID: 20140102004001
Gaia: b1bc88386c781148a25091bf2eeee3ba217281d0
Gecko: 0c11156c7d9b
Version: 26.0
RIL Version: 01.02.00.019.102
Firmware Version: v1.2_20131115
Keywords: qawanted
Can we double check if this happens on 1.3 & 1.4?
Keywords: qawanted
This issue still occurs in 1.3 and 1.4. Data from the previous week is not deleted until app is manually closed and relaunched using the task manager. Also, the start and end dates displayed on the graph do not update to display the new week.

Environmental Variables:
Device: Buri v1.3 Moz
BuildID: 20140102004001
Gaia: 01e9da49be2cc4bc134eeefc434740d572ec2246
Gecko: 61f553e5db49
Version: 28.0a2
RIL Version: 01.02.00.019.102
Firmware Version: 20131115

Device: Buri v1.4 Moz Ril
BuildID: 20140102040201
Gaia: 67a82f88da231969efa4d22df9fb946abf2cf4df
Gecko: 540d85f60c57
Version: 29.0a1
RIL Version: 01.02.00.019.102
Firmware Version: 20131115
Keywords: qawanted
What happens if you do the following:

1. Setup the weekly billing period was setup
2. Kill the cost control app
3. Surf the web to generate data usage
4. Move the date to a future date such that the next weekly billing period gets triggered
5. Check the data usage counter

Trying to understand if the STR can only possibly happen with the cost control running in the background.
Flags: needinfo?(rkuhlman)

Updated

4 years ago
Keywords: regression
Following the steps from comment 9:
The app updates appropriately when launched in the latest 1.3 and Master build.

I also tried out a few variations by altering the order of steps. In every instance, the cost control app displayed appropriately after being closed and relaunched. The usage app only displays inappropriate content when the user manually changes the date while Usage is running.



I speculate that the usage app has a timer variable that tracks the clock and updates the graph accordingly. By changing the date, the timer never gets triggered because it never hit the required timestamp. I suggeset adding a function to the Usage app that updates the graph every time the user manually adjusts the date. The same function should probably also be called when the device crosses a time zone and the time is automatically updated.
Flags: needinfo?(rkuhlman)
In that case - this is a minor regression that users likely won't hit.
(In reply to rkuhlman from comment #10)
> I speculate that the usage app has a timer variable that tracks the clock
> and updates the graph accordingly. By changing the date, the timer never
> gets triggered because it never hit the required timestamp. I suggeset
> adding a function to the Usage app that updates the graph every time the
> user manually adjusts the date. The same function should probably also be
> called when the device crosses a time zone and the time is automatically
> updated.

The Cost Control application has an alarm (not a timer) to trigger reset when the proper date is hit. This must be checked. Thanks for the catching.
(Reporter)

Updated

4 years ago
Whiteboard: burirun4, burirun1.3-1 → burirun4, burirun1.3-1, burirun1.4-1
(Reporter)

Comment 13

4 years ago
If date is changed to future it is working
Status: REOPENED → RESOLVED
Last Resolved: 4 years ago4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.