[traceback] TypeError list indices must be integers, not str - mkt.webapps.utils in dehydrate_content_rating

RESOLVED FIXED in 2013-11-26

Status

RESOLVED FIXED
5 years ago
5 years ago

People

(Reporter: vcarciu, Assigned: kngo)

Tracking

({regression})

Avenir
2013-11-26
x86_64
Windows 7
regression
Points:
---

Details

(URL)

(Reporter)

Description

5 years ago
Prerequisites:
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:28.0) Gecko/20100101 Firefox/28.0

Steps to reproduce:
1.Go to MP Stage homepage 
2.Try to sort the apps by newest

Expected results:
Apps are correctly sorted

Actual results:
Internal server error message is displayed

Please see screencast for this bug : http://screencast.com/t/Ml6OPMOa

NOTES:
Not reproducible on -dev
Looks like http://sentry.dmz.phx1.mozilla.com/addons/marketplace-stage/group/17208/

mkt.webapps.utils in dehydrate_content_rating
/api/v1/fireplace/search/featured/: TypeError list indices must be integers, not str

Updated

5 years ago
Component: Consumer Pages → API
Summary: Internal server error occurred when sorting apps by newest on Stage → [traceback] TypeError list indices must be integers, not str - mkt.webapps.utils in dehydrate_content_rating
(Assignee)

Comment 2

5 years ago
https://github.com/mozilla/zamboni/pull/1447
Assignee: nobody → kngo
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.