v8 regression - windows 7 and 8 PGO only

RESOLVED WONTFIX

Status

RESOLVED WONTFIX
5 years ago
5 years ago

People

(Reporter: jmaher, Unassigned)

Tracking

({perf, regression})

Trunk
All
Windows 8
perf, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [talos_regression])

(Reporter)

Description

5 years ago
A regression has been reported on the V8 test, on windows 7 and 8 only.

Here is a graph of the regression (higher is better):
http://graphs.mozilla.org/graph.html#tests=[[230,63,31]]&sel=none&displayrange=30&datatype=running

and you can see it on datazilla:
https://datazilla.mozilla.org/?start=1384879215&stop=1385484015&product=Firefox&repository=Mozilla-Inbound&os=win&os_version=6.2.9200&test=v8_7&graph_search=9a179f9b33ca&x86=false&x86_64=true&project=talos

this is specifically a regression in the regexp test, but the splay test became quite variable.

I have looked for this in non-PGO builds and don't see it.  This seems to show up when this spreads to other branches (seen after merged into Fx-Team, on PGO only).

There is a larger range of pushes here:
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=ad3f19e7c0fc&tochange=9a179f9b33ca

Code for regexp test is here:
http://hg.mozilla.org/build/talos/file/9eddc69c813e/talos/page_load_test/v8_7/regexp.js

Code for splay is here:
http://hg.mozilla.org/build/talos/file/9eddc69c813e/talos/page_load_test/v8_7/splay.js

I am thinking it could be from bug 941821, but I have no way to know.  I would need to trigger some PGO builds on the intermediate builds and see if I an narrow the changeset down.

:terrence, any chance these tests could be affected by your change?
(Reporter)

Updated

5 years ago
Flags: needinfo?(terrence)
I know they aren't the exact same benchmarks, but FWIW bug 941424 was also implicated in performance regressions on AWFY. See bug 941424 comment #18 and on - but no word yet on what the cause could be (e.g. whether the generated code changed).
(Reporter)

Comment 2

5 years ago
I will follow along in the other bug, if there is anything I can do to experiment or help get more details numbers, let me know.
That patch is an annotation for the Hf builds. It is a nop in opt builds.
Flags: needinfo?(terrence)
(Reporter)

Comment 4

5 years ago
this was partially fixed, then we hit a new regression in March which hasn't been filed.

here is the history of v8 (higher is better):
http://graphs.mozilla.org/graph.html#tests=[[230,63,31]]&sel=none&displayrange=365&datatype=running

here is a link to the new regression:
https://groups.google.com/forum/#!topic/mozilla.dev.tree-management/u65dqEj80q0

appears to be related to bug 785905, although in the past week that has mostly been fixed and we don't see this regression on aurora:
http://graphs.mozilla.org/graph.html#tests=[[230,63,31],[230,52,25],[230,52,31]]&sel=1387893531432,1395669531432&displayrange=90&datatype=running

Since this original bug is already on release, and other regressions/improvements have been made, I am going to mark this as wontfix.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.