The shader editor highlighting acts weirdly when there's a custom framebuffer attachment on the default renderbuffer

VERIFIED FIXED in Firefox 27

Status

defect
P3
normal
VERIFIED FIXED
6 years ago
4 months ago

People

(Reporter: vporof, Assigned: vporof)

Tracking

unspecified
Firefox 28
Dependency tree / graph

Firefox Tracking Flags

(firefox26 unaffected, firefox27 verified, firefox28 verified)

Details

Attachments

(1 attachment)

STR:

1. Open Shader Editor on http://david.li/waves/
2. Hover the "Program {n}" items on the left

The rendering starts acting super strange.

This is pretty much a followup for bug 938549, where I didn't anticipate that custom framebuffers might be attached to the default renderbuffer, in which case we should suppress highlighting, just like we do when rendering to depth textures.
Summary: The shader editor highlighting acts weirdly on http://david.li/waves/ → The shader editor highlighting acts weirdly when there's a custom framebuffer attachment on the default renderbuffer
Assignee: nobody → vporof
Status: NEW → ASSIGNED
Attachment #8338813 - Flags: review?(rcampbell)
Depends on: 938549
Priority: -- → P3
Comment on attachment 8338813 [details] [diff] [review]
webgl-highlight-2.patch

Review of attachment 8338813 [details] [diff] [review]:
-----------------------------------------------------------------

no comment!
Attachment #8338813 - Flags: review?(rcampbell) → review+
Comment on attachment 8338813 [details] [diff] [review]
webgl-highlight-2.patch

[Approval Request Comment]
Bug caused by (feature/regressing bug #): This is a very small followup for bug 938549.
User impact if declined: Some pages still act weirdly when the Shader Editor is opened (see comment 0).
Testing completed (on m-c, etc.): fx-team
Risk to taking this patch (and alternatives if risky): None
String or IDL/UUID changes made by this patch: None
Attachment #8338813 - Flags: approval-mozilla-aurora?
https://hg.mozilla.org/mozilla-central/rev/b9250086cf18
Status: ASSIGNED → RESOLVED
Closed: 6 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → Firefox 28
Target Milestone: Firefox 28 → ---
Target Milestone: --- → Firefox 28
Attachment #8338813 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
Verified as fixed using Firefox 27 beta 7 (20140116125114) and latest Aurora 28.0a2 (20140116004003) under Win 7 64-bit, Ubuntu 32-bit and Mac OSX 10.9.

Hovering from "Program 0" to "Program 5" had no effect on the waves, hover the "Program 6" changed the animation color.
Status: RESOLVED → VERIFIED
Keywords: verifyme
QA Contact: petruta.rasa
Product: Firefox → DevTools
Product: DevTools → DevTools Graveyard
You need to log in before you can comment on or make changes to this bug.