Closed Bug 943779 Opened 8 years ago Closed 8 years ago

Need to update the images displayed while the contact tab is loading with the new visuals

Categories

(Firefox OS Graveyard :: Gaia::Dialer, defect)

x86_64
Linux
defect
Not set
normal

Tracking

(b2g-v1.3 fixed)

RESOLVED FIXED
Tracking Status
b2g-v1.3 --- fixed

People

(Reporter: etienne, Assigned: rik)

References

Details

Attachments

(2 files)

While we load the contact tab in the Dialer, we display an empty "header" [1].
The images used for this are out of date, so it clashes with the new visuals.

[1] https://github.com/mozilla-b2g/gaia/blob/master/apps/communications/dialer/style/dialer.css#L95-103
Bye bye images!
Assignee: nobody → anthony
Status: NEW → ASSIGNED
Attachment #8341182 - Flags: review?(etienne)
Comment on attachment 8341182 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14273

r=me with nits
Attachment #8341182 - Flags: review?(etienne) → review+
Merged in https://github.com/mozilla-b2g/gaia/commit/f9901db71b8e5a70da1700ae82b66231bc000660
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
This patch seems to make dialer keys inoperable since the grid-wrapper has a weird new height and captures pointer events.
Blocks: 946276
No longer blocks: 946276
Depends on: 946276
(In reply to Eitan Isaacson [:eeejay] from comment #4)
> This patch seems to make dialer keys inoperable since the grid-wrapper has a
> weird new height and captures pointer events.

Looks like this is then the cause of bug 946276.
[master bf2feba] Revert "Merge pull request #14273 from Rik/contact-in-dialer-fake-943779"

This caused issues and was reverted on master.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
What kind of test should be added that can be run *before landing* which checks things like this?
(In reply to Dietrich Ayala (:dietrich) from comment #7)
> What kind of test should be added that can be run *before landing* which
> checks things like this?

I think the resolution of bug 891882 will allow us to enable for Travis some dialer tests that already exist.

Although it sounds like in this case even just building Gaia onto a phone and trying to make a call would have caught this.
Attachment #8343846 - Flags: review?(etienne)
Yeah, it was my fault. I was working on this patch and wanted to land it before a two days training. I rushed it and didn't test as much as I do usually. Lesson learned.
Comment on attachment 8343846 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14468

All for the best :)

Thanks everyone for catching this, next step in on bug 947863.
Attachment #8343846 - Flags: review?(etienne) → review+
Merged with https://github.com/mozilla-b2g/gaia/commit/7252dc37bcf7ff907af9c41720dd8891f935b4dd.

Will re-test on the device, just in case.
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
Duplicate of this bug: 964495
Comment on attachment 8343846 [details] [review]
https://github.com/mozilla-b2g/gaia/pull/14468

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): noticed by QA in bug 964495
[User impact] if declined: Flash of old style
[Testing completed]: Almost two months on master
[Risk to taking this patch] (and alternatives if risky): Low and easy to back out
[String changes made]: No
Attachment #8343846 - Flags: approval-gaia-v1.3?(fabrice)
Attachment #8343846 - Flags: approval-gaia-v1.3?(fabrice) → approval-gaia-v1.3+
Uplifted 7252dc37bcf7ff907af9c41720dd8891f935b4dd to:
v1.3: 247900c8257fd7c18425d2c9d65a94ac156d4be9
You need to log in before you can comment on or make changes to this bug.